Bug 117044 - 2.6.3-1.110 and 116 oops (don't boot) on Thinkpad T30 with acpi enabled
Summary: 2.6.3-1.110 and 116 oops (don't boot) on Thinkpad T30 with acpi enabled
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
: 117065 117094 117244 118150 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-27 18:22 UTC by Mathieu Chouquet-Stringer
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 19:07:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mathieu Chouquet-Stringer 2004-02-27 18:22:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040217 Galeon/1.3.13

Description of problem:
The latest 2.6.3-1.110 (from Rawhide) doesn't boot on a IBM thinkpad
T30 (all the previous releases worked). Passing the option acpi=off
makes the system boot again.

Here's the output (from serial console log):

drivers/acpi/ec.c:357: spin_is_locked on uninitialized spinlock c1562854.
Unable to handle kernel paging request at virtual address 80314ba0
 printing eip:
c01d8201
*pde = 00000000
Oops: 0000 [#1]
CPU:    0
EIP:    0060:[<c01d8201>]    Not tainted
EFLAGS: 00010046
EIP is at acpi_os_read_memory+0x25/0x53
eax: c0314ba0   ebx: 00000008   ecx: c1577f48   edx: c0314ba0
esi: 00000008   edi: c0314ba0   ebp: dff4e938   esp: c1577f20
ds: 007b   es: 007b   ss: 0068
Process events/0 (pid: 3, threadinfo=c1576000 task=c1578cc0)
Stack: c1577f48 c1577f48 c01e323b 00000008 00000282 00000282 c1562820
00000282 
       c15622a8 c01eef98 00000000 33323130 37363534 42413938 46454443
c15622a8 
       00000297 c01d84ce c15622b0 c0136f11 c01d84c2 c1576000 ffffffff
ffffffff 
Call Trace:
 [<c01e323b>] acpi_hw_low_level_read+0x4b/0x98
 [<c01eef98>] acpi_ec_gpe_query+0xea/0x1a5
 [<c01d84ce>] acpi_os_execute_deferred+0xc/0x15
 [<c0136f11>] worker_thread+0x21a/0x31d
 [<c01d84c2>] acpi_os_execute_deferred+0x0/0x15
 [<c01205a7>] default_wake_function+0x0/0xc
 [<c01205a7>] default_wake_function+0x0/0xc
 [<c0136cf7>] worker_thread+0x0/0x31d
 [<c013aac2>] kthread+0x64/0x8c
 [<c013aa5e>] kthread+0x0/0x8c
 [<c01091d5>] kernel_thread_helper+0x5/0xb

Code: 0f b6 82 00 00 00 c0 88 01 eb 1e 0f b7 82 00 00 00 c0 66 89 


Version-Release number of selected component (if applicable):
2.6.3-1.110

How reproducible:
Always

Steps to Reproduce:
1. Install 2.6.3-1.110
2. Boot
3. Oops
    

Additional info:

Comment 1 Mathieu Chouquet-Stringer 2004-03-01 16:37:43 UTC
Still present in 2.6.3-1.116

Comment 2 Dave Jones 2004-03-01 23:38:45 UTC
ah, this has been known about for a while.
there's an ugly fix for it in tonights kernel, but this needs fixing
properly at some point.

(triage folks: I think there's an open bugzilla on this already.)

Comment 3 Bill Nottingham 2004-03-02 05:01:40 UTC
*** Bug 117065 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2004-03-02 05:24:04 UTC
*** Bug 117094 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2004-03-02 05:58:24 UTC
*** Bug 117244 has been marked as a duplicate of this bug. ***

Comment 6 Arjan van de Ven 2004-03-10 17:11:48 UTC
should be fixed in rawhide; please confirm

Comment 7 Mathieu Chouquet-Stringer 2004-03-10 19:07:51 UTC
It's fixed.

Comment 8 Nick Marsh 2004-03-16 15:13:03 UTC
*** Bug 118150 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.