Bug 1172618 - [RFE] [Fedora] Allow anonymous pull from Zanata
[RFE] [Fedora] Allow anonymous pull from Zanata
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 3.6
Assigned To: Alex Eng
Zanata-QA Mailling List
:
Depends On:
Blocks: Zanata-3.6.1 1206995
  Show dependency treegraph
 
Reported: 2014-12-10 08:19 EST by Vojtech Trefny
Modified: 2015-04-19 23:10 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: 3
Clone Of:
: 1206995 (view as bug list)
Environment:
Last Closed: 2015-04-19 20:29:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vojtech Trefny 2014-12-10 08:19:30 EST
Pulling translations from Zanata currently requires login/apikey. It would be great if anonymous users could pull translations.

It would allow us to include a "translation update" target directly into Makefile without forcing people to create an account at Zanata.org or without storing po files in Git repository.

Currently for example Anaconda uses downloading new translation files as part of make target for a new version release (we are using Transifex, (that also doesn't allow anonymous pull) but with planned Fedora to switch to Zanata, anonymous pulls would be really great for us).
Comment 1 Vratislav Podzimek 2014-12-10 08:41:19 EST
There are many projects that would really welcome such feature.
Comment 2 Martin Kolman 2015-01-07 06:10:41 EST
I'm the maintainer of Initial Setup and python-meh, both of which will also use Zanata for translation in the near future, so I would also appreciate anonymous pull support in Zanata, so that users/potential-contributors could build these two applications more easily (without the need to register somewhere).
Comment 3 Carlos Munoz 2015-01-13 21:15:18 EST
Notes from our estimation:

- Only for pull source and translation, stats (project level and contributor level).
- Rate limiting by IP
  - Verify it works with direct jboss, Apache, nginx type setups
Comment 4 Alexander Todorov 2015-02-24 07:52:10 EST
+1 from a user stand point. 

I'm currently trying to build anaconda from git and don't even have an account with Transifex or Zanata.
Comment 5 David Cantrell 2015-03-06 15:37:22 EST
This is a huge workflow issue right now.  Can the priority be increased on this functionality?  The functionality right now requires any contributors to our projects to also set up a Zanata account just to do local test builds of projects.  This is because our build process pulls down the latest translations at build time, which then feeds in to the images that are built.

This was a limitation in Transifex too, it would be nice to not also have the same limitation in Zanata.
Comment 6 Michelle Kim 2015-03-09 18:48:48 EDT
Thanks everyone for your comments. As I see increased demand for this feature, I am moving this RFE to high priority in our backlog.
Comment 7 Alex Eng 2015-03-18 22:57:08 EDT
Security implementation for Zanata server:

| Client          | Authenticated | Allowed action(Server) |
------------------------------------------------------------
| have zanata.ini | Yes           | READ/WRITE             | 
| have zanata.ini | No            | READ                   |
| no zanata.ini   | No            | READ                   |
------------------------------------------------------------
Comment 8 Alex Eng 2015-03-18 23:14:20 EDT
Updated: Security implementation for Zanata server:

| Client             | Authenticated | Allowed action(Server) |
---------------------------------------------------------------
| username/apiKey    | Yes           | READ/WRITE             | 
| username/apiKey    | No            | REJECT                 |
| no username/apikey | No            | READ                   |
---------------------------------------------------------------
Comment 9 Ding-Yi Chen 2015-03-19 20:43:52 EDT
Note that client also need to modify to delegate the check to server.
Comment 12 Brian Lane 2015-03-26 13:01:52 EDT
Please remember that we (Anaconda team) are using zanata-python-client in our build scripts. This applies to Fedora as well as RHEL6 and RHEL7.
Comment 13 Alex Eng 2015-03-26 16:44:10 EDT
This feature involve changes in Zanata-server as well as supported zanata-client (see http://zanata.org/help/cli/cli-install/ for supported client).

However, we are in the progress of bringing our python client up to scratch but unfortunately it's not part of this development.

But as current Zanata user that has authentication, you still can use zanata-python-client to do translation pull from our server.

We will track changes of python client for anonymous pull as separate bug.
Comment 14 Ding-Yi Chen 2015-03-29 21:56:54 EDT
VERIFIED Zanata 3.6.1-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3141)
Comment 15 Ding-Yi Chen 2015-03-29 22:07:50 EDT
(In reply to bcl@redhat.com from comment #12)
> Please remember that we (Anaconda team) are using zanata-python-client in
> our build scripts. This applies to Fedora as well as RHEL6 and RHEL7.

zanata-python-client anonymous support should be tracked using Bug 1206995
Comment 17 Ding-Yi Chen 2015-03-31 02:44:41 EDT
zanata-client-3.6.0-1 is pushed to bodhi branch rawhide, fc22, fc21, fc20
Comment 18 Alex Eng 2015-04-19 23:05:08 EDT
Python client request: https://bugzilla.redhat.com/show_bug.cgi?id=1213205
Comment 19 Alex Eng 2015-04-19 23:10:40 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=1206995 for python client

Note You need to log in before you can comment on or make changes to this bug.