Bug 1174036 - Review Request: ocaml-re - OCaml regular expression library
Summary: Review Request: ocaml-re - OCaml regular expression library
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Richard W.M. Jones
URL:
Whiteboard:
: 1174035 1174039 1266011 (view as bug list)
Depends On:
Blocks: FE-NEEDSPONSOR 1185099 1486068
TreeView+ depends on / blocked
 
Reported: 2014-12-15 00:15 UTC by Jon Ludlam
Modified: 2018-08-23 15:37 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-29 20:09:00 UTC
rjones: fedora-review+


Attachments (Terms of Use)

Description Jon Ludlam 2014-12-15 00:15:08 UTC
Spec URL: http://www.recoil.org/~jon/ocaml-re.spec
SRPM URL: http://www.recoil.org/~jon/ocaml-re-1.2.2-2.fc21.src.rpm
Description:

A pure OCaml regular expression library. Supports Perl-style regular
expressions, Posix extended regular expressions, Emacs-style regular
expressions, and shell-style file globbing.  It is also possible to
build regular expressions by combining simpler regular expressions.
There is also a subset of the PCRE interface available in the Re.pcre
library.

Fedora Account System Username: jonludlam

Koji link: http://koji.fedoraproject.org/koji/taskinfo?taskID=8383840

Comment 1 Robin Lee 2014-12-15 01:57:59 UTC
*** Bug 1174035 has been marked as a duplicate of this bug. ***

Comment 2 Robin Lee 2014-12-15 01:58:10 UTC
*** Bug 1174039 has been marked as a duplicate of this bug. ***

Comment 3 Richard W.M. Jones 2015-01-23 18:12:49 UTC
Usually better for patches to be '*.patch' since it makes it
clearer what the file is when looking at the git repo.

You probably don't need a newline after %description.  Not sure
what rpm does - whether it ignores it or adds whitespace to the
rpm header.

Rest looks fine to me.

Comment 4 Jon Ludlam 2015-01-24 22:31:56 UTC
Thanks Richard. Fixed those two.

Spec URL: http://www.recoil.org/~jon/ocaml-re.spec
SRPM URL: http://www.recoil.org/~jon/ocaml-re-1.2.2-3.fc21.src.rpm

Comment 5 Richard W.M. Jones 2015-02-24 10:14:56 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "LGPL (v2.1 or later)", "Unknown or generated". 22 files have unknown
     license. Detailed output of licensecheck in /home/rjones/1174036-ocaml-
     re/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[?]: %build honors applicable compiler flags or justifies otherwise.

Consider replacing 'make' with 'make %{?_smp_mflags}' (assuming
that works).

[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[x]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[-]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.

Ocaml:
[x]: This should never happen

RWMJ - I have no idea what this means.  fedora-review is broken.

===== SHOULD items =====

Generic:
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[!]: Uses parallel make %{?_smp_mflags} macro.

See comment above.

[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[?]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in ocaml-re-
     devel

You probably need to add %{?_isa} as described.

[x]: Package functions as described.
[x]: Latest version is packaged.
[-]: Package does not include license text files separate from upstream.
[-]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[ ]: Package should compile and build into binary rpms on all supported
     architectures.
[ ]: %check is present and all tests pass.
[ ]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: ocaml-re-1.2.2-3.fc21.x86_64.rpm
          ocaml-re-devel-1.2.2-3.fc21.x86_64.rpm
          ocaml-re-1.2.2-3.fc21.src.rpm
ocaml-re.x86_64: W: spelling-error %description -l en_US globbing -> globing, gobbing, lobbing
ocaml-re.x86_64: W: spelling-error %description -l en_US pcre -> pare, acre, pore
ocaml-re.src: W: spelling-error %description -l en_US globbing -> globing, gobbing, lobbing
ocaml-re.src: W: spelling-error %description -l en_US pcre -> pare, acre, pore
ocaml-re.src:43: W: rpm-buildroot-usage %build ocaml setup.ml -configure --destdir $RPM_BUILD_ROOT
3 packages and 0 specfiles checked; 0 errors, 5 warnings.


You can ignore these.

Requires
--------
ocaml-re (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    ocaml(Array)
    ocaml(Buffer)
    ocaml(Char)
    ocaml(Format)
    ocaml(Hashtbl)
    ocaml(List)
    ocaml(Map)
    ocaml(Pervasives)
    ocaml(Re)
    ocaml(Re_emacs)
    ocaml(Re_perl)
    ocaml(String)
    ocaml(runtime)
    rtld(GNU_HASH)

ocaml-re-devel (rpmlib, GLIBC filtered):
    ocaml-re



Provides
--------
ocaml-re:
    ocaml(Automata)
    ocaml(Cset)
    ocaml(Re)
    ocaml(Re_emacs)
    ocaml(Re_glob)
    ocaml(Re_pcre)
    ocaml(Re_perl)
    ocaml(Re_posix)
    ocaml(Re_str)
    ocaml-re
    ocaml-re(x86-64)

ocaml-re-devel:
    ocaml-re-devel
    ocaml-re-devel(x86-64)



Source checksums
----------------
https://github.com/ocaml/ocaml-re/archive/ocaml-re-1.2.2/ocaml-re-1.2.2.tar.gz :
  CHECKSUM(SHA256) this package     : fdc5233c8ff14394f39b0137029fd61f36cc17c703cbd54b173a94cdb827d62e
  CHECKSUM(SHA256) upstream package : fdc5233c8ff14394f39b0137029fd61f36cc17c703cbd54b173a94cdb827d62e


Generated by fedora-review 0.5.2 (63c24cb) last change: 2014-07-14
Command line :/usr/bin/fedora-review -b 1174036
Buildroot used: fedora-21-x86_64
Active plugins: Generic, Shell-api, Ocaml, C/C++
Disabled plugins: Java, Python, SugarActivity, fonts, Haskell, Perl, R, PHP, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG

Comment 6 Richard W.M. Jones 2015-02-24 10:15:48 UTC
This package is APPROVED by rjones, but please check the items
mentioned in the review above.

Comment 7 Jon Ludlam 2015-02-24 14:08:44 UTC
Thanks again Richard. Looks like the "make %{?_smp_mflags}" change breaks the build. It works for the latest git version, so we can put it in if we upgrade. I had a quick look through the git log to see if there was an obvious change that fixed it, but I couldn't immediately see it. I've fixed the {isa} thing though.

Spec URL: http://www.recoil.org/~jon/ocaml-re.spec
SRPM URL: http://www.recoil.org/~jon/ocaml-re-1.2.2-4.fc21.src.rpm

Comment 8 Upstream Release Monitoring 2015-10-21 22:58:46 UTC
jonludlam's scratch build of ocaml-re-1.4.1-1.fc23.src.rpm for f23 completed http://koji.fedoraproject.org/koji/taskinfo?taskID=11536753

Comment 9 Jon Ludlam 2015-10-21 23:00:46 UTC
New upstream release:

Spec URL: http://www.recoil.org/~jon/ocaml-re.spec
SRPM URL: http://www.recoil.org/~jon/ocaml-re-1.4.1-1.fc23.src.rpm

and Koji build as per previous comment.

Comment 10 Igor Gnatenko 2016-08-14 15:53:18 UTC
still not in rawhide.

Comment 11 Ben Rosser 2017-08-15 19:18:31 UTC
Since the package review was approved, it was proposed on the devel list that this just get imported.

However, the spec and SRPM are no longer available from the links above, and there have been several new releases of ocaml-re since 2015. (Also, I needed a build of ocaml-re to start looking at ocaml-dose, another opam dependency).

I grabbed a copy of the spec from Jon's copr repository: http://copr-dist-git.fedorainfracloud.org/cgit/jonludlam/opam/ocaml-re.git/plain/ocaml-re.spec?h=f23, and updated the version to 1.7.1.

I had to make a minor modification or two to get it to build from that version of the spec; there's (now?) a configure script upstream, which I just invoked directly. However the documentation gets put in the wrong place (%{buildroot}%{_docdir}/re rather than .../ocaml-re), so I remove it in %install and install it manually.

Otherwise, I made no changes to Jon's package.

Spec URL: https://tc01.fedorapeople.org/ocaml/opam/ocaml-re.spec
SRPM URL: https://tc01.fedorapeople.org/ocaml/opam/ocaml-re-1.7.1-1.fc26.src.rpm

I can open a new review, if you'd prefer.

Comment 12 Robert-André Mauchin 2017-08-29 08:03:08 UTC
> Submitter not responding
>
>    When the submitter of a review ticket has not responded to comments for one month, a comment is added to the ticket indicating that the review is stalled and that a response is needed soon.
>    If there is no response within one week, the ticket is closed with resolution NOTABUG, and the fedora-review flag is set to the empty value.
>    The bug may be set as blocking FE-DEADREVIEW. The intention is to close the bug so that it can be submitted by someone else in a separate bug, and also to make it easy to find bugs closed in this way. 
>
>If the bug is resubmitted by someone else, it is also reasonable to change the resolution on the closed bug to DUPLICATE and mark it as a duplicate of the new bug so that reviewers of the new ticket can easily find the work that was done on the old one.


Jon Ludlam, could you please create the repo and build the package since it has been accepted? Otherwise, we'll mark this as a dead review.

Comment 13 Richard W.M. Jones 2017-08-29 08:18:39 UTC
Grumble ..

$ fedrepo-req -t 1174036 ocaml-re
Error: The Bugzilla ticket's review was approved over 60 days ago

I will give the new package in comment 11 and quick re-review ...

Comment 14 Richard W.M. Jones 2017-08-29 09:22:44 UTC
All the issues found and fixed in the original package review
remain fixed in the update package in comment 11, therefore
I'm approving this again.

Comment 15 Richard W.M. Jones 2017-08-29 09:30:45 UTC
https://pagure.io/releng/fedora-scm-requests/issue/596

Comment 16 Gwyn Ciesla 2017-08-29 10:26:58 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/ocaml-re

Comment 17 Richard W.M. Jones 2017-08-29 10:35:30 UTC
Thanks Gwyn.  I'm still waiting for permissions to propagate so
I can push to the repo, but in the meantime here is a scratch build
for testing purposes:

https://koji.fedoraproject.org/koji/taskinfo?taskID=21526932

Comment 18 Richard W.M. Jones 2017-08-29 13:18:03 UTC
https://pagure.io/releng/issue/7003

Comment 20 Ben Rosser 2018-08-23 15:37:37 UTC
*** Bug 1266011 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.