Bug 117411 - Modules not loading during startup.
Summary: Modules not loading during startup.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-03 18:36 UTC by Mark Lane
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 2.6.4-1.275
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 19:06:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modprobe.conf (6.13 KB, text/plain)
2004-03-09 19:20 UTC, Mark Lane
no flags Details

Description Mark Lane 2004-03-03 18:36:17 UTC
Description of problem:
After upgrading, some modules no longer load during startup.

Good example is the floppy module. I have also seen that the alsa oss
compat modules are not loading as well.


Version-Release number of selected component (if applicable):
initscripts-7.46-1.1

I have seen this with both a custom 2.6.3 kernel and kernel-2.6.3-1.118

How reproducible:
We have two machines not loading the modules.

Comment 1 Bill Nottingham 2004-03-04 04:19:46 UTC
Not loading as in loading them fails, or they aren't getting loaded
when they should be?

Note that both of these should be loaded on demand.

Comment 2 Timo Kujala 2004-03-09 10:03:38 UTC
Yes, same thing here. For example, loop device doesn't load when
needed. Neither does the nvidia driver. Modprobing them they load just
fine, but kernel simply won't load them when needed.
I did some tracing in the kernel but that really did not help =)
kobj_lookup does not find anything from the map, looks like the major
numbers aren't initialized or something.

Comment 3 Mark Lane 2004-03-09 16:16:29 UTC
Not loading when demanded. I have to load the floppy module by hand. 
The Alsa OSS emulation stuff is the same. My modprobe.conf lists it 
with the regular alsa modules.  

Comment 4 Bill Nottingham 2004-03-09 19:02:04 UTC
What modutils packages do you have installed? What does your
modprobe.conf look like?

Comment 5 Mark Lane 2004-03-09 19:20:16 UTC
Created attachment 98409 [details]
modprobe.conf

I have modutils-2.4.26-6 installed.

currently this machine is running a custom 2.6.3 kernel. Our dual Opteron
system isn't hooked up so I am not sure what version of modutils it's running.
The last kernel installed was on the Opteron was 2.6.3-1.118.

Comment 6 Bill Nottingham 2004-03-09 21:12:17 UTC
Aha, reproduced here.

Comment 7 Bill Nottingham 2004-03-09 22:27:14 UTC
/sbin/modprobe isn't getting called at all for kmod-type events ->
kernel bug.

Comment 8 Mark Lane 2004-03-09 22:35:00 UTC
NOTE: I have seen this both with the Fedora Devel Kernels (2.6.3) 
and a custom build kernel built with straight kernel.org sources. 

Comment 9 Mark Lane 2004-03-12 01:26:21 UTC
I just compiled a new custom version of 2.6.4 with patches for 
x86_64 (x86_64-2.6.4rc3.bz2 patch from x86-64.org) and the lastest 
alsa patch. Now the floppy modules loads. So I don't know what 
changed as it worked before 2.6.3 and it works after.  

Comment 10 Arjan van de Ven 2004-03-15 10:31:28 UTC
Andi Kleen's patch got accepted by linus and is in the 2.6.4 kernel
rpms now.

Comment 11 Timo Kujala 2004-03-17 18:29:42 UTC
Yep, 2.6.4-1.275 works correctly.


Note You need to log in before you can comment on or make changes to this bug.