Bug 117458 - yum is broken in current devel
yum is broken in current devel
Status: CLOSED DUPLICATE of bug 117290
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-04 03:15 EST by Michael Wyraz
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Wyraz 2004-03-04 03:15:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040217

Description of problem:
after installing the current devel and running yum first the bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=117410 (missing
file) occurs. after fixing this, all search/install actions results in:

Gathering header information file(s) from server(s)
Server: Fedora Core 1.90 - Development Tree
Finding updated packages
Downloading needed headers
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 253, in main
    clientStuff.download_headers(HeaderInfo, nulist)
  File "/usr/share/yum/clientStuff.py", line 919, in download_headers
    cachedbdict = returnCacheDBHeaders(nulist)
  File "/usr/share/yum/clientStuff.py", line 901, in returnCacheDBHeaders
    mi = cachedb.dbMatch()
UnboundLocalError: local variable 'cachedb' referenced before assignment


Version-Release number of selected component (if applicable):
yum-2.0.5.20040229-1

How reproducible:
Always

Steps to Reproduce:

    

Additional info:
Comment 1 Michael Wyraz 2004-03-04 03:29:05 EST
i solved the problem using an (older?) yum:

* download yum-2.0.5-1.noarch.rpm from
http://linux.duke.edu/projects/yum/download.ptml

* save /etc/yum.conf

* install the rpm (using "rpm -uvh yum-2.0.5-1.noarch.rpm --force")

after removing the old yum pidfile it works fine.

I't important to tell yum not to update again to the broken version
(please write a comment if you know how - i dont't ;) )
Comment 2 Miloslav Trmac 2004-03-04 09:04:23 EST

*** This bug has been marked as a duplicate of 117290 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.