Bug 1174948 - [RFE] Have Pulp support Basic Authentication in Repo URL's
Summary: [RFE] Have Pulp support Basic Authentication in Repo URL's
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
: 1201986 1266499 1278520 (view as bug list)
Depends On:
Blocks: 1317008 260381 1171330 1175448 1281611
TreeView+ depends on / blocked
 
Reported: 2014-12-16 20:13 UTC by Thom Carlin
Modified: 2019-09-25 20:49 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this release, users of Red Hat Satellite 6.2 can sync down repositories protected by basic authentication by providing the username and password in the repository string.
Clone Of:
: 1281611 (view as bug list)
Environment:
Last Closed: 2016-07-27 09:12:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
password protected repo url (95.04 KB, image/png)
2015-12-18 09:13 UTC, Tazim Kolhar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Red Hat Knowledge Base (Solution) 2137231 None None None 2016-02-23 09:33:40 UTC

Description Thom Carlin 2014-12-16 20:13:45 UTC
Description of problem:

Unable to use basic authentication in Sat6 Repository

Version-Release number of selected component (if applicable):

6.0.6

How reproducible:

Every time

Steps to Reproduce:
1. Create a new repo with URL of form: "https://user:password@host/path_to_file
2.
3.

Actual results:

"An error occurred saving the Repository: is invalid

Expected results:

Repository x saved

Additional info:

Comment 1 RHEL Product and Program Management 2014-12-16 20:24:04 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Michael Hrivnak 2014-12-17 19:27:52 UTC
I tested this with pulp 2.5.0 on centos7, and I was able to sync a yum repo. I made a small yum repo on a local machine, used apache to enforce basic auth, and put those credentials in the feed url.

$ pulp-admin rpm repo create --repo-id=foo --feed="http://me:letmein@myhost/foo/"

I suggest testing this with sat 6.1, and it may just work.

Comment 5 Eric Helms 2015-05-22 23:56:13 UTC
The Katello project added this support a few months back (http://projects.theforeman.org/issues/6637) and it should be available in the upcoming 6.1 release. As Michael said, I would suggest testing this out and closing this bug if it indeed works for you.

Comment 6 Bryan Kearney 2015-05-23 00:03:55 UTC
Upstream bug assigned to jsherril@redhat.com

Comment 7 Bryan Kearney 2015-05-23 00:03:56 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6637 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|a1c597d1ce5883d1b99d45551c81b4077e560ae7.

Comment 8 Thom Carlin 2015-06-01 11:16:41 UTC
No longer onsite at Alcoa, so unable to test.

Comment 9 Michael Hrivnak 2015-06-01 13:22:11 UTC
In the future (pulp 2.7+), pulp will accept a username and password as config option for the repo, so you won't need to put them in the URL.

https://pulp.plan.io/issues/163

Comment 11 Bryan Kearney 2015-10-08 12:49:48 UTC
*** Bug 1266499 has been marked as a duplicate of this bug. ***

Comment 12 Bryan Kearney 2015-10-08 14:43:00 UTC
*** Bug 1201986 has been marked as a duplicate of this bug. ***

Comment 15 Tazim Kolhar 2015-12-18 09:11:41 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***
Version Tested:

# rpm -qa | grep foreman
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
foreman-debug-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-ovirt-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
foreman-postgresql-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-vmware-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
foreman-gce-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
dell-per300-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-release-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
foreman-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-libvirt-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
dell-per300-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-per300-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201512101420git81ec371.el7.noarch
foreman-compute-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
foreman-proxy-1.11.0-0.develop.201512101505git62c9e22.el7.noarch

steps:
1. Create a new repo with URL of form: "https://user:password@host/path_to_file
2.
3.

Repository saved

screenshot attached

Comment 16 Tazim Kolhar 2015-12-18 09:13:37 UTC
Created attachment 1107054 [details]
password protected repo url

Comment 17 Brad Buckingham 2016-02-22 18:31:15 UTC
*** Bug 1278520 has been marked as a duplicate of this bug. ***

Comment 22 errata-xmlrpc 2016-07-27 09:12:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.