This service will be undergoing disruptive maintenance at 7:00PM UTC, 2020-01-18. It is expected to last approximately one hour.
Bug 1175260 - After rebooting the controller and compute VMs they're stuck for a long time on "no route to host"
Summary: After rebooting the controller and compute VMs they're stuck for a long time ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-17 11:37 UTC by Udi
Modified: 2015-08-05 13:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the VM console showing the errors (35.93 KB, image/png)
2014-12-17 11:37 UTC, Udi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Udi 2014-12-17 11:37:18 UTC
Created attachment 970058 [details]
Screenshot of the VM console showing the errors

Description of problem:
With the instack setup on virtual machines, when you restart the VM it takes it too long to boot, and it logs the same error numerous times: "no route to host". See attached screenshot.


How reproducible:
100%


Steps to Reproduce:
1. Install using instack-virt-setup, instack-install-undercloud and instack-deploy-overcloud
2. Restart the compute and controller VMs (with libvirt, destroy and launch Baremetal_X domains)
3. Open the console to the VMs like in the attached screenshot.


Actual results:
The same error repeats in a loop over and over again. Eventually it stops but I didn't wait to measure exactly how long it takes.


Additional info:
When rebooting the VM, it first gets stuck on PXE boot and you need to send it ctrl+alt+del to start the boot process again. Then you see the above errors... There is also a bug reported on the PXE problem (bug #1174293).

Comment 6 Udi 2015-06-29 10:52:59 UTC
Looks good with puddle 2015-06-26

Comment 8 errata-xmlrpc 2015-08-05 13:50:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.