Bug 117608 - UnboundLocalError: local variable 'cachedb' referenced before assignment
Summary: UnboundLocalError: local variable 'cachedb' referenced before assignment
Status: CLOSED DUPLICATE of bug 117290
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-05 19:23 UTC by Petri T. Koistinen
Modified: 2014-01-21 22:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petri T. Koistinen 2004-03-05 19:23:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040122 Debian/1.6-1

Description of problem:
[root@dsl-hkigw4db2 root]# yum update
 
Unable to find pid
Gathering header information file(s) from server(s)
Server: Fedora Core 1.90 - Development Tree
Finding updated packages
Downloading needed headers
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 253, in main
    clientStuff.download_headers(HeaderInfo, nulist)
  File "/usr/share/yum/clientStuff.py", line 919, in download_headers
    cachedbdict = returnCacheDBHeaders(nulist)
  File "/usr/share/yum/clientStuff.py", line 901, in returnCacheDBHeaders
    mi = cachedb.dbMatch()
UnboundLocalError: local variable 'cachedb' referenced before assignment


Version-Release number of selected component (if applicable):
yum-2.0.5.20040229-1

How reproducible:
Always

Steps to Reproduce:
1. # yum update

Expected Results:  Just do it.

Additional info:

Comment 1 Miloslav Trmac 2004-03-05 19:25:43 UTC

*** This bug has been marked as a duplicate of 117290 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.