Bug 117614 - Traceback after partitioning and pressing next
Traceback after partitioning and pressing next
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC2Blocker FC3Target 133260
  Show dependency treegraph
 
Reported: 2004-03-05 15:20 EST by Kjartan Maraas
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 22:33:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is what anaconda asked me to save to floppy when it crashed (375.57 KB, text/plain)
2004-05-22 18:07 EDT, David Holden
no flags Details
anaconda dump from same error (37.92 KB, text/plain)
2004-06-17 16:04 EDT, Timothy
no flags Details
Dump from a RHL 9 installation. (67.26 KB, text/plain)
2004-09-08 16:31 EDT, Hans Deragon
no flags Details

  None (edit)
Description Kjartan Maraas 2004-03-05 15:20:07 EST
Description of problem:
Started an install on a HP Compaq nc8000 laptop and it got as far as
partitioning before I started running into problems.

- automatic partitioning failed, and I got some warnings about
aligning partitions before entering that screen. These were said to be
ignorable though

- manual partitioning with Disk Druid resulted in:

File "/usr/lib/anaconda/gui.py", line 762, in nextClicked
  rc = self.currentWindow.getNext()
File "/usr/lib/anaconda/iw/partition_gui.py", line 636, in getNext
  (errors, warnings) =
self.partitions.sanityCheckAllRequests(self.diskset)
File "/usr/lib/anaconda/partitions.py", line 820, in
sanityCheckAllRequests
  swapSize = swapSize + request.getActualSize(self, diskset)
File "/usr/lib/anaconda/partRequests.py", line 450, in getActualSize
  raise RuntimeError, "Checking the size of a partition which hasn't
been allocated yet"



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2004-03-05 15:22:36 EST
Adding some more info.

This machine was set up with one NTFS partition with XP on. Then an
extended partition with three more Win9x partitions which I deleted
and created

/home  - 15 GB
/      - 14 GB
<swap> - 1 GB
/boot  - 100 MB

Comment 2 Jeremy Katz 2004-03-05 17:09:59 EST
This is a bug that pops up from time to time that I can't reproduce at
all :(   Do you have a reliable means of reproducing?  Can you grab
the /tmp/anacdump.txt somehow (since I'm guessing you don't have a
floppy and hence why you didn't attach the dump :)
Comment 3 Colin Charles 2004-05-07 08:24:01 EDT
Kjartan, has this been fixed for you with FC2 test3?
Comment 4 Kjartan Maraas 2004-05-08 06:39:30 EDT
I'm afraid I'm going to have a hard time reproducing this as I'd have
to wipe all my partitions and repartition with Windows 2000 partitions
etc since that was the original setup when I started out with FC2
test1. I'll install test3 and see if it behaves with what I have now
at least, but I think this can be closed if nobody else has seen it.
Comment 5 David Holden 2004-05-22 18:07:27 EDT
Created attachment 100463 [details]
This is what anaconda asked me to save to floppy when it crashed
Comment 6 David Holden 2004-05-22 18:09:14 EDT
I *think* I have a similar problem, on install of fedora core 2 (the
final version) after partitioning I crashed out witha traceback,
attached in comment number 5.

When I tried installing again it did not get past the first screen
your presented with either in graphics or text mode.
Comment 7 Timothy 2004-06-17 16:04:54 EDT
Created attachment 101227 [details]
anaconda dump from same error

This is the anaconda dump that applies to this error.

My drive is 76 GB. I have three(3) partitions that were partitioned and
formated in Copy Commander:
1: Primary, (15 gb) WinXP fresh install
Extended (61 GB)
   15 GB empty space for Fedora
   2. 15 GB NTFS, empty
   3. 31 GB NTFS, empty

This Western Digital drive is hooked up through a Manhattan RAID card, but is
not currently being mirrored.

BTW, Linux is "Greek" to me at this point, but everyone has to start somewhere
:-)
I am trying to dual boot my XP with Fedora Core 2 final.
   The first attempt failed as I tried to install Fedora on the 15 GB chunk
left outside the Extended partition. Since I had been mirroring this drive to a
smaller drive, some space had been lost due to shrinking. I decided to fill
this extra space with an empty partition. I thought this would force Fedora to
install in only the 15 GB chunk set aside. It didn't work.
   I then repartitioned the whole drive to allow Fedora to install inside the
Extended partition. The results are in the dump file.
   I will state that I connected a 28 GB drive to the same RAID card that had a
fresh install of XP on one partition (the rest of the drive was free). This
setup did work, and Fedora worked fine. Therefore, provided its not the RAID
channel, the RAID card should not be a problem as I see it.

   I am going to erase all the partitions after the 15GB XP and see if Fedora
will accept my peace offering. lol

If you have any tips, please feel free to throw them my way :-)

Timothy
Comment 8 Hans Deragon 2004-09-08 16:31:41 EDT
Created attachment 103608 [details]
Dump from a RHL 9 installation.

This problem exist since RHL 9, as I suffer from it too.  Commenting out the
"part" instructions in the kickstart file and forcing Anaconda to ask the user
to partition manually the disk allowed me to proceed with the installation. 
Attached, anacdump.txt from a RHL 9 installation.
Comment 9 Jeremy Katz 2004-09-27 22:33:31 EDT
I _believe_ this will be fixed for FC3 test3 (at least, a way that I
managed to reproduce it is fixed).
Comment 10 shamim 2004-11-09 06:04:24 EST
 I have tried installing FC3 , i faced the same problems when ever i
selected automatic partitioning ,it gave error failed, then I tried
manual partition , it took all the space of 26GB ,but how do I define
the space for FEDORA on my hard drive which has 29GB for XP and other
partition is 26GB , I dont want to use the whole 26GB for Fedora ? may
be just 10GB would be enough for boot, root and swap, even if I do the
automatic partitioning ,would it give me the option of deciding the space.
can any one let me know how to acheive this

shamim@g7tc.com

Note You need to log in before you can comment on or make changes to this bug.