Bug 117650 - install on external USB harddisk is not quite there
install on external USB harddisk is not quite there
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
: 117649 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-06 02:43 EST by Paul Ionescu
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 17:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Ionescu 2004-03-06 02:43:25 EST
Description of problem:
I have an IBM T40 thinkpad and an external 20G USB2 harddrive.
I want to install and boot FC2 test1 on this USB harddrive.
For this, I select "expert" mode at the beginnig of instalation,
otherwise the USB hard is not available for install.
After that, everything is installing fine, except that the created
initrd image for booting the system does not contain the drivers for 
USB+scsi and thus is not detecting the root harddrive.
Moreover, I requested that GRUB should be installed on /dev/sda and
not the default /dev/hda, but it didn't install on /dev/sda.
After install went OK, I could not boot the system because of the
forementioned issues. I managed to boot the old linux from my internal
hard, and did some tricks to boot the new FC2test1 from usb.
The tricks were:
Create a initrd image with drivers for USB+some scsi+usb_storage, boot
 the FC2 test1, do an grub-install by hand, and that was it.
Now I can boot FC2 from my external USB2 harddrive.



Version-Release number of selected component (if applicable):
Fedora Core 2 test1

How reproducible:
Always

Steps to Reproduce:
1.install FC2 on usb2 harddrive
2. try to boot from that drive
3. 
  
Actual results:
it doesn't boot

Expected results:
shoult boot OK, and insert the usb stuff for finding the usb disk.
this should not be so hard to fix because I think it already does this
for scsi discs. It just have to know that USB disks are like scsi
disks and they need kernel modules x,y.

Additional info:
It may be not only x86 specific, but I tested this only on my thinkpad
(which is in fact i686). Anyway, I suspect this is true for all paltforms.
Comment 1 Paul Ionescu 2004-03-06 02:51:14 EST
*** Bug 117649 has been marked as a duplicate of this bug. ***
Comment 2 Paul Ionescu 2004-05-01 17:55:24 EDT
I tested again with FC2 test3 and the results are improving:

I installed the FC2 test3 on a external USB disk, using the "linux
expert" option at boot time.
GRUB was installed properly, and I was able to boot from that USB hard
afterwards.
However, the usb modules were not in the ramdisk, so it could not
mount the root disk. I had to do it manualy again. (edit the ramdisk
and put the needed modules in there).
Comment 3 Jeremy Katz 2004-05-06 17:02:17 EDT
This isn't done by default somewhat intentionally...  mkinitrd if run
with --with-usb will include the modules and things might then work. 
But it's still not something that we're really supporting very well
and I'm not completely convinced of how interesting it is to do so.
Comment 4 Kim Lux 2004-10-29 14:41:56 EDT
I think it is a VERY interesting thing to do, for a couple of reasons:

a) I'm tired of downloading ISO, burning disks and doing media checks
on them.

a2) One could have the entire installation set ie rpms and source rpms
on the same disk !  No more CD shuffling !

b) We are going to use Linux on a bunch of stand alone workstations
that aren't networked and don't have CDROMs.  We move data on and off
of them via USB devices.  AFAIK USB devices are the new floppy drive. 

c) I've got a laptop that I'd love to be able to set up to boot from
external drives.  The internal drive is 80BG, and I've got that set up
as XP and my working Linux, but I'd love to be able to have it boot a
different Linux install, say a test install, from an external drive. 
My laptop BIOS won't support booting from a USB device, so the boot
loader will need to be /dev/hda, but everything else could be on a USB
drive. 


I am very excited about this.  I re installed Linux twice this week so
I could test on my laptop.  I could have kept my old install and ran
the test installs from the external drive.  We use removable drives
mounted in drawers and now our external IDE enclosure has a drawer
slot in it too.  I could set up (run, configure, etc.) the software
for the workstations on my laptop and then transfer the removable
drive to the workstation.  That would be outstanding.  

Note You need to log in before you can comment on or make changes to this bug.