Bug 117665 - TCP ECN should be disabled by default until the rest of the world stops sucking
Summary: TCP ECN should be disabled by default until the rest of the world stops sucking
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: distribution   
(Show other bugs)
Version: 1.0
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 117745 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-06 19:39 UTC by Nicholas Miell
Modified: 2014-03-17 02:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 19:38:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A handy-dandy patch to the three flavors of sysctl.conf (1.28 KB, patch)
2004-03-06 19:46 UTC, Nicholas Miell
no flags Details | Diff

Description Nicholas Miell 2004-03-06 19:39:13 UTC
This isn't technically a bug in any Linux software, but the
interoperability problems are going to confuse the hell out of users
anyway.

Basically, 2.6 kernels have TCP ECN enabled by default. Unfortunately,
everybody else craps themselves when they see packets with the ECN bit
set, resulting in "myserious web sites that I can't connect to"-type
problems.

So, until the rest of the networking world is dragged kicking and
screaming into, well, 1999 or so, /etc/sysctl.conf should have
"net.ipv4.tcp_ecn = 0" in it.

Comment 1 Nicholas Miell 2004-03-06 19:46:13 UTC
Created attachment 98345 [details]
A handy-dandy patch to the three flavors of sysctl.conf

New! and Improved! Bug: Now with Minimal Effort Required!

Comment 2 Petri T. Koistinen 2004-03-06 20:06:16 UTC
Nothing gets fixed until something breaks. So it's good to break
things in order to get things fixed. Minor break is not fixed, major
is. Better break more when you breaking things. Keep the default.

Comment 3 Bill Nottingham 2004-03-08 16:40:24 UTC
That doesn't help upgrades though. Arjan: what's the plan on the
kernel-level default?

Comment 4 Bill Nottingham 2004-03-08 20:13:25 UTC
*** Bug 117745 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2005-03-02 19:38:47 UTC
I don't think this is going to be changed in sysctl.conf. I believe
the kernel defaults to off these days.


Note You need to log in before you can comment on or make changes to this bug.