Bug 117745 - TCP ECN is enabled by default, breaking some net connections
Summary: TCP ECN is enabled by default, breaking some net connections
Status: CLOSED DUPLICATE of bug 117665
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-08 03:00 UTC by Brian L
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian L 2004-03-08 03:00:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
Kernel has TCP ECN (Explicit Congestion Notification) enabled by
default, which some routers (notably the popular Netgear SOHO variety)
do not handle correctly, effectively breaking TCP connections accross
that router.

Version-Release number of selected component (if applicable):
kernel-2.6.1-1.65

How reproducible:
Always

Steps to Reproduce:
1.Fedora Core2 Test 1 behind Netgear WGR614 with latest firmware 1126
2.Attempt HTTP connection to external system
(http://fedora.redhat.com)    

Actual Results:  Ping + Traceroute + DNS to internet hosts OK
Timeouts in Mozilla, Konquerer, Lynx, and in raw telnet to port 80.
Manually disabling ECN as below restores functionality until reboot:
echo "0" > /proc/sys/net/ipv4/tcp_ecn



Expected Results:  Mozilla, Konquerer, and Lynx should be able to
access http://fedora.redhat.com

Additional info:

Workaround to disable ECN using command:
echo "0" > /proc/sys/net/ipv4/tcp_ecn

Comment 1 Bill Nottingham 2004-03-08 20:13:22 UTC

*** This bug has been marked as a duplicate of 117665 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.