Bug 117668 - gstreamer-properties can't test esdsink
gstreamer-properties can't test esdsink
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-06 15:54 EST by John Thacker
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 02:22:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
One line patch to fix audio pipeline for testing output sinks (786 bytes, patch)
2004-03-06 15:55 EST, John Thacker
no flags Details | Diff

  None (edit)
Description John Thacker 2004-03-06 15:54:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
gstreamer-properties incorrectly claims that esdsink doesn't work when
a user tries to test it after setting the default output sink to
esdsink.  Despite this claim, if esd is active the sink may be working
anyway.  (esd will only work if the user has upgraded to
esound-0.2.33-1 due to bug 114326 )

This is because esdsink can't play sinesrc directly, unlike other
output sinks.  I.e., gst-launch sinesrc ! esdsink fails. 
Audioconversion is necessary first.

The correct test pipeline to use would involve using the spider plugin
to hook together the sources and sinks, to automatically take care of
such problems.  sinesrc ! spider ! esdsink works, as does any other sink.

Line 34 of gstreamer-properties/pipeline-constants.c should be changed
to read:
static gchar audiosink_test_pipe[] = "sinesrc freq=512 ! spider";

Patch provided below


Version-Release number of selected component (if applicable):
gnome-media-2.5.4-2

How reproducible:
Always

Steps to Reproduce:
1. gstreamer-properties
2. Select "esdsink" as default output sink
3. Push "Test" button


Actual Results:  Error message about inability to create pipeline pops up.

Expected Results:  Test sound, a pure sine wave, should play.

Additional info:

Note that esdsink still works anyway, so this is only to make the test
work properly and remove a confusing error message.
Comment 1 John Thacker 2004-03-06 15:55:52 EST
Created attachment 98346 [details]
One line patch to fix audio pipeline for testing output sinks
Comment 2 John Thacker 2004-03-06 15:56:50 EST
I also filed an upstream bug
http://bugzilla.gnome.org/show_bug.cgi?id=136407
Comment 3 John Thacker 2004-03-11 02:22:10 EST
Fixed upstream in gnome-media-2.5.5, and thus will make it into FC2
before release with the rest of GNOME2.6

Note You need to log in before you can comment on or make changes to this bug.