Bug 117676 - aumix produces debug info on start
aumix produces debug info on start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Eido Inoue
:
: 98210 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-06 19:06 EST by Scott Sloan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.20.1-46
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-31 15:10:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture of the problem (22.88 KB, image/png)
2004-03-06 19:07 EST, Scott Sloan
no flags Details

  None (edit)
Description Scott Sloan 2004-03-06 19:06:27 EST
Description of problem:

I attached a screenshot of the problem. when I start aumix from the
console, debug information is written on top of the interface

Version-Release number of selected component (if applicable):

aumix-2.8-7.EL

How reproducible:

every time

Steps to Reproduce:
1. Lunch gnome-terminal
2. run aumix
Comment 1 Scott Sloan 2004-03-06 19:07:39 EST
Created attachment 98348 [details]
picture of the problem
Comment 2 Bill Nottingham 2004-03-08 15:09:00 EST
This is coming from libgpm.
Comment 3 Scott Sloan 2004-03-08 19:00:36 EST
my version of gpm is 

gpm-1.20.1-43
Comment 4 Moritz Barsnick 2004-03-21 17:08:06 EST
Same problem in w3m here. These messages are to stderr, so calling 
the program using "program 2>/dev/null" temporarily works around  
this problem, but it's a really really big pain.
Comment 5 Scott Sloan 2004-03-21 19:56:48 EST
fixed in the latest builds
Comment 6 Scott Sloan 2004-03-30 19:02:20 EST
This bug reappears in FC2 test2 
Comment 7 Eido Inoue 2004-03-31 15:10:20 EST
*** Bug 98210 has been marked as a duplicate of this bug. ***
Comment 8 Moritz Barsnick 2004-04-08 16:08:25 EDT
I'm still seeing this in gpm-1.20.1-46, but with w3m, not with aumix. 
They must be using different calls? w3m and aumix are both linked 
dynamically against libgpm.so.1. w3m is self-built (CVS version), not 
from Fedora.
Comment 9 Eido Inoue 2004-04-08 16:17:23 EDT
Check the linkage. The string "VC: " appears only once in liblow.c,
and has been commented out with a "#if 0", so I don't understand how
you can still be receiving that diagnostic msg
Comment 10 Moritz Barsnick 2004-04-17 15:31:39 EDT
I now understand how I can still be receiving messages - they're 
different messages. ;-) This may be a different bug:

I get messages only when running w3m in rxvt:

*** err [lib/liblow.c(266)]:
strncmp/isdigit/consolename failed
[lib/liblow.c(377)]:
Oh, oh, it's an error! possibly I die!

w3m keeps running.

If I remove the offending source around line 266, w3m actually 
segfaults.

I'll check whether this has to do with my w3m build and post a new 
bug report.

Thanks,
Moritz

Note You need to log in before you can comment on or make changes to this bug.