Bug 117687 - Rescue boot needs prelink for rpm verify to work
Summary: Rescue boot needs prelink for rpm verify to work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-07 04:59 UTC by Ben Smith
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 16:02:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Smith 2004-03-07 04:59:21 UTC
Description of problem:

When running rpm --verify from the 'rescue' boot option on the install
CD, rpm is confused by prelinked binaries (since prelink is not
available) and mistakenly reports them as modified.

How reproducible:

100%

Steps to Reproduce:
1.  Boot from install cd
2.  Select 'linux rescue'
3.  Follow the instructions and mount your root partition.
4.  rpm -r /mnt/sysimage -Va
  
Actual results:

Prelinked binaries are reported as having changed size/md5sum.

Expected results:

RPM should detect prelinked binaries.

Additional info:

AFAICT, the prelink binary just needs to be added to the 'rescue'
image.  That should enable rpm to correctly detect prelinked binaries.

Comment 1 Ben Smith 2004-04-14 11:56:12 UTC
See also bug 106523

Comment 2 Jeremy Katz 2004-05-06 21:06:37 UTC
Added in CVS

Comment 3 Ben Smith 2004-06-19 23:26:22 UTC
Tested with FC2 and, while prelink is present, it also needs a 
couple of configuration files in order to work properly: 
 
/etc/prelink.conf <-- can be blank, but should be present 
/etc/rpm/macros.prelink <-- from the prelink package 
 
'/etc/rpm/macros.prelink' just needs to contain the following line: 
%__prelink_undo_cmd     /usr/sbin/prelink prelink -y library 
 

Comment 4 Jeremy Katz 2004-10-07 18:03:29 UTC
Fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.