Bug 117693 - pango crashes because it can't find builtin or dynamically loaded modules
Summary: pango crashes because it can't find builtin or dynamically loaded modules
Status: CLOSED DUPLICATE of bug 114399
Alias: None
Product: Fedora
Classification: Fedora
Component: pango   
(Show other bugs)
Version: 2
Hardware: powerpc Linux
medium
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-07 10:50 UTC by jeroen
Modified: 2010-09-28 20:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pango.modules (1.94 KB, text/plain)
2004-03-07 10:52 UTC, jeroen
no flags Details

Description jeroen 2004-03-07 10:50:52 UTC
Version: pango-1.3.5-1
From:
ftp://download.fedora.redhat.com/pub/fedora/linux/core/development/ppc/

When i try to start either gdm or gnome-session, they crash with the
following output:

[jeroen@orcrist jeroen]$ gnome-session
SESSION_MANAGER=local/orcrist:/tmp/.ICE-unix/5215
                                                                     
          
** (gnome-session:5215): WARNING **: No builtin or dynamically loaded
modules
were found. Pango will not work correctly. This probably means
there was an error in the creation of:
  '/etc/pango/pango.modules'
You may be able to recreate this file by running pango-querymodules.
                                                                     
          
(gnome-session:5215): GLib-GObject-CRITICAL **: file gobject.c: line
1561 (g_object_ref): assertion `G_IS_OBJECT (object)' failed
                                                                     
          
** (gnome-session:5215): CRITICAL **: file pango-engine.c: line 68
(_pango_engine_shape_shape): assertion `PANGO_IS_FONT (font)' failed
                                                                     
          
** ERROR **: file shape.c: line 75 (pango_shape): assertion failed:
(glyphs->num_glyphs > 0)
aborting...

There *is* a /etc/pango/pango.modules. (by default there isn't: it's
put in /etc/pango/ppc-redhat-linux-gnu). I've run
pango-querymodules-32 > /etc/pango/pango.modules and tried again, but
it keeps crashing.

I'm out of ideas here. My system is fully updated with the fedora ppc
development yum repository. This is a major problem for me since
practically everything with a GUI uses pango nowadays.

Comment 1 jeroen 2004-03-07 10:52:17 UTC
Created attachment 98355 [details]
pango.modules

Comment 2 Paul Nasrat 2004-03-07 12:06:26 UTC
This is a duplicate of
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=114399

Work around as documented in earlier bug report

cd /etc/pango
ln -s ppc-redhat-linux-gnu powerpc-redhat-linux-gnu

This works around it for me.

triage->duplicate 114399

Comment 3 Miloslav Trmac 2004-03-07 14:49:03 UTC

*** This bug has been marked as a duplicate of 114399 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:01:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Comment 5 Dan Hale 2010-09-28 20:30:51 UTC
I found that restrictive permissions can cause this symptom, too.  Our site sets root's umask to 077, which breaks all kinds of things.  After I fixed the perms and this problem went away.

find /opt/freeware -perm 600 -exec chmod 644 {} \;

This was on AIX with the install of the Linux Toolbox RPMs.


Note You need to log in before you can comment on or make changes to this bug.