Bug 114399 - arch-specific pango.modules location incorrect
Summary: arch-specific pango.modules location incorrect
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pango   
(Show other bugs)
Version: 1.0
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
: 117045 117693 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-27 18:20 UTC by Guy Streeter
Modified: 2016-02-10 01:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 13:41:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Guy Streeter 2004-01-27 18:20:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
On powerpc, up2date attempts to open
/etc/pango/powerpc-redhat-linux-gnu/pango.modules
but the location is actually
/etc/pango/ppc-redhat-linux-gnu/pango.modules

Further, the error message references /etc/pango/pango.modules, which
is not actually what it is looking for.

Version-Release number of selected component (if applicable):
pango-1.3.2-2

How reproducible:
Always

Steps to Reproduce:
1. run up2date on a ppc system
2.
3.
    

Actual Results:  ** (up2date:9477): WARNING **: No builtin or
dynamically loaded modules
were found. Pango will not work correctly. This probably means
there was an error in the creation of:
  '/etc/pango/pango.modules'


Expected Results:  no errors

Additional info:

Comment 1 W. Michael Petullo 2004-02-02 23:02:26 UTC
I have the same problem on my PowerPC-based system.  If I cp -a
/etc/pango/ppc-redhat-linux-gnu to etc/pango/powerpc-redhat-linux-gnu
then pango applications work fine.

Comment 2 W. Michael Petullo 2004-02-12 17:41:56 UTC
This bug exists in the RPM shipped with Fedora Core 2 Test 1.

Comment 3 Miloslav Trmac 2004-03-07 14:49:05 UTC
*** Bug 117693 has been marked as a duplicate of this bug. ***

Comment 4 Owen Taylor 2004-03-17 14:30:14 UTC
*** Bug 117045 has been marked as a duplicate of this bug. ***

Comment 5 W. Michael Petullo 2004-03-30 01:20:39 UTC
This bug exists in the RPM shipped with Fedora Core Test 2.

Comment 6 Guy Streeter 2004-04-14 21:08:02 UTC
This appears to be fixed in rawhide

Comment 7 Guy Streeter 2004-04-14 21:09:29 UTC
erk. I didn't mean to close it

Comment 8 W. Michael Petullo 2004-05-02 23:36:42 UTC
I also see this as fixed in rawhide.  Keep this one closed.


Note You need to log in before you can comment on or make changes to this bug.