Bug 1177002 - comps display_order for environment groups not respected by installer with dnf payload (or dnf itself)
Summary: comps display_order for environment groups not respected by installer with dn...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All All
unspecified
high
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1196651 (view as bug list)
Depends On:
Blocks: F22AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-12-23 18:06 UTC by Adam Williamson
Modified: 2015-02-26 13:56 UTC (History)
13 users (show)

Fixed In Version: hawkey-0.5.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-20 08:32:32 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Williamson 2014-12-23 18:06:34 UTC
When using the dnf package payload in the installer (recent Rawhide composes), the environment groups are ordered exactly as they appear in comps-f22.xml.in - not according to their display_order values. This means the default env group is Fedora Cloud Server, as that's the first listed environment.

When using the yum payload - booting with 'nodnf' - the display_order values are respected and Fedora Server is the default environment group, as expected.

The installer does not appear to do any of the comps processing work itself, but with the dnf payload it will be using libcomps, not yum's comps lib, so filing against libcomps.

Note also that 'dnf group list' shows the available and installed groups in alphabetical order, but 'yum group list' respects the display_order values.

This is a high priority bug as it will result in the wrong package set being the default for the Server network install image. This should probably be a Beta or Final blocker, but we don't appear to have a criterion that would cover it. I'll draft one. Proposing as an Alpha Freeze Exception for now.

Comment 1 Jindrich Luza 2015-01-02 08:34:53 UTC
Hi

Libcomps doesn't modify order of groups in input comps file, thats why it could be different from groups ordered by display_order attribute. First group in comps.xml file is first group in comps.groups list.

I think this is more dnf issue than libcomps.  Libcomps is more like library providing functions for comps manipulation rather than high-level 1:1 API for strictly dnf purpose.

Comment 2 Honza Silhan 2015-01-15 13:48:24 UTC
dnf.comps.Comps.groups/group_by_pattern/groups_by_pattern and dnf.comps.Comps.environments/environment_by_pattern/environments_by_pattern DNF API methods are ordering groups by `display_order` in this PR. Ordering is honored in `dnf group list` output too.

[1] https://github.com/rpm-software-management/dnf/pull/193

Comment 3 Fedora Update System 2015-02-16 00:03:19 UTC
dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21

Comment 4 Fedora Update System 2015-02-17 08:04:14 UTC
Package hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.3-2.fc21 dnf-plugins-core-0.1.5-1.fc21 dnf-0.6.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2139/dnf-plugins-core-0.1.5-1.fc21,hawkey-0.5.3-2.fc21,dnf-0.6.4-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-02-20 08:32:32 UTC
hawkey-0.5.3-2.fc21, dnf-plugins-core-0.1.5-1.fc21, dnf-0.6.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 David Shea 2015-02-26 13:56:50 UTC
*** Bug 1196651 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.