Bug 1196651 - order of items in Software Selection should be deterministic and always the same
Summary: order of items in Software Selection should be deterministic and always the same
Keywords:
Status: CLOSED DUPLICATE of bug 1177002
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-26 13:02 UTC by Jan Sedlák
Modified: 2015-02-26 13:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-26 13:56:50 UTC
Type: Bug


Attachments (Terms of Use)
Software Selection when using yum (138.21 KB, image/png)
2015-02-26 13:02 UTC, Jan Sedlák
no flags Details
Software Selection when using dnf (136.61 KB, image/png)
2015-02-26 13:02 UTC, Jan Sedlák
no flags Details

Description Jan Sedlák 2015-02-26 13:02:27 UTC
Created attachment 995573 [details]
Software Selection when using yum

Description of problem:
In addition to bug 1192155, order of items in Software Selection is different whether you use dnf or yum (with inst.nodnf boot option). We are trying to automate anaconda testing and this thing complicate it for us.

I would also argue that "Minimal install" should be on higher place than the last one.

Version-Release number of selected component (if applicable):
22.20.1-1

Comment 1 Jan Sedlák 2015-02-26 13:02:53 UTC
Created attachment 995574 [details]
Software Selection when using dnf

Comment 2 Kamil Páral 2015-02-26 13:39:24 UTC
I think the interesting question here is whether anaconda does something to modify the order, or whether it takes it unaltered from yum/dnf. Second, whether the order provided by yum/dnf is somehow consistent and configured (and by whom?), or is it just a random representation of the underlying comps xml. And third, would anaconda consider sorting the list somehow (probably not just by alphabet, but also placing the most prominent Fedora flavors at the top), or do you not want to touch this?

Thanks.

Comment 3 David Shea 2015-02-26 13:56:50 UTC
There was a recent update for dnf to order comps by display_order, as yum does. If that turns out not have worked please reopen this bug.

*** This bug has been marked as a duplicate of bug 1177002 ***


Note You need to log in before you can comment on or make changes to this bug.