Bug 1177156 - [RFE] Ability to clone a running VM directly from GUI
Summary: [RFE] Ability to clone a running VM directly from GUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ovirt-4.4.3-1
: ---
Assignee: Shmuel Melamud
QA Contact: Tamir
URL:
Whiteboard:
: 1341856 (view as bug list)
Depends On: 1215845 1891306
Blocks: 1417161 1839058
TreeView+ depends on / blocked
 
Reported: 2014-12-24 15:55 UTC by Luca Villa
Modified: 2020-11-24 13:12 UTC (History)
14 users (show)

Fixed In Version: ovirt-engine-4.4.3.10
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-24 13:12:40 UTC
oVirt Team: Virt
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:5215 None None None 2020-11-24 13:12:46 UTC
oVirt gerrit 111313 master ABANDONED core: Clone a running VM 2021-01-14 16:25:32 UTC
oVirt gerrit 111490 master MERGED core: Clone a running VM 2021-01-14 16:25:30 UTC

Description Luca Villa 2014-12-24 15:55:11 UTC
1. Proposed title of this feature request
      
Ability to clone a running VM
      

    3. What is the nature and description of the request?  

Add the ability to clone a vm while it's running through a simple GUI operations.
      
    4. Why does the customer need this? (List the business requirements here)  

It's not infrequent that a running VM, which cannot be stopped due to business continuity reasons, needs to be cloned. This operation cannot be performed in RHEV 3.5 directly.                  
      
    5. How would the customer like to achieve this? (List the functional requirements here)  

Right-click on a running VM in the Admin Portal and choose "Clone" from the contextual menu to fire the guided process that drives to the creation of a new cloned VM.
      
    6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  

a. Select a running VM in Admin portal.
b. right-click on it and verify that the "Clone" item is available in the contextual menu.
c. Select "Clone" and look the wizard start
d. follow the instructions of the wizard and verify that a new VM is created and that it's a clone of the original VM
e. The original running VM shouldn't be affected in its normal operations by the cloning process.

Comment 2 Michal Skrivanek 2015-01-09 08:34:26 UTC
note it is possible today
you can create a live snapshot and clone a VM from there, then (ideally) live merge it back to the original image
This is how the RFE would be implemented internally anyway, though a convenient UI shortcut is desired

Comment 3 Michal Skrivanek 2015-01-09 08:35:53 UTC
this is pending Command Coordination framework improvements, to be less cumbersome to use for chaining backend commands

Comment 5 Michal Skrivanek 2015-06-05 12:13:34 UTC
This bug did not make it in time for 3.6 release, moving out

Comment 6 Michal Skrivanek 2015-06-05 13:40:15 UTC
*** Bug 1226622 has been marked as a duplicate of this bug. ***

Comment 7 Michal Skrivanek 2015-06-05 13:41:18 UTC
make sure to unblock in snapshot subtab as well, as requested in bug 1226622

Comment 10 Michal Skrivanek 2016-03-22 07:37:50 UTC
open question is what to do with guest settings (NIC's MAC, etc).
with or without RAM.

Comment 11 Michal Skrivanek 2016-09-07 12:42:07 UTC
*** Bug 1341856 has been marked as a duplicate of this bug. ***

Comment 12 Michal Skrivanek 2016-09-07 12:45:29 UTC
we should use bug 1335642 to clear the new clone's config

Comment 13 Yaniv Kaul 2016-11-21 09:51:16 UTC
Can we provide an Ansible script providing this functionality?

Comment 14 Michal Skrivanek 2016-12-14 12:16:46 UTC
probably yes, but PM doesn't seem to be happy with it, so deferring to 4.2

Comment 15 Martin Tessun 2017-03-16 09:48:20 UTC
We should try getting this done in 4.2.
As Ansible integration moves forward, maybe even an Ansible script that does the above described steps from comment 2 might suffice, but I believe we need a UI element that would trigger the Ansible scripts.

So what I personally think is an easy way to be consumed by customers is a way of having UI entries (like Clone VM) which trigger an Ansible script that is installed on the Manager that does all the steps and reports back to the UI (or creates some audit_log entries to verify its successful completion).

Thoughts?

Comment 19 Martin Tessun 2017-05-17 11:57:13 UTC
This can be done with Ansible scripts today. Is this a feasible approach.

Moran: Can you provide the Ansible plugins that are needed for that.

Overall approach:
1. Snapshot the VM.
2. Clone from the Snapshot
3. Remove the Snapshot.

This will not be implemented in the RHV UI though, but can be implemented in CFME instead.

Comment 26 spower 2018-07-03 11:28:20 UTC
We agreed to remove the component RFEs from bugzilla. If you feel the component is incorrectly renamed please reach out.

Comment 32 Shmuel Melamud 2020-09-07 01:05:03 UTC
Implementation plan:

1. Create a new command that is executed by the existing "Clone VM" UI action, if the target VM is running.
2. The command runs the following commands in order: create a VM snapshot, create a VM from the snapshot, delete the snapshot.
3. No changes are made in the newly created VM, besides assigning a new MAC address to NIC.
4. Memory image is not created.
5. REST API call is not implemented.

Comment 34 Tamir 2020-10-25 13:32:56 UTC
I tested the regular usage of the following feature on RHV 4.4.3-10 and I found an error that stopped me from testing further.
I opened the related bug: https://bugzilla.redhat.com/show_bug.cgi?id=1891306

Also found another related low severity bug: https://bugzilla.redhat.com/show_bug.cgi?id=1891303

Comment 36 Michal Skrivanek 2020-11-02 17:32:28 UTC
fixing bug 1891306 makes this feature usable

Comment 40 Tamir 2020-11-08 18:30:08 UTC
I verified the bug on RHV 4.4.3-13.

Env:
  - Engine instance with RHV 4.4.3-13 (ovirt-engine-4.4.3.10-0.1.el8ev) and RHEL 8.3 installed.
  - 3 hosts with RHV 4.4.3-13 and RHEL 8.3, vdsm-4.40.35.1-1.el8ev


I executed the tests I wrote in the "Polarion Requirement", most of the tests passed and I posted bugs for the issues I stumbled upon.

While the verification I stumbled upon those 3 bugs:

- Bug 1895695 - Modifying (add/remove/replace) NICs in the clone modal doesn't reflect on the cloned VM (https://bugzilla.redhat.com/show_bug.cgi?id=1895695)
- Bug 1895697 - Modifying disk allocation target domain in the clone modal doesn't reflect on the cloned VM (https://bugzilla.redhat.com/show_bug.cgi?id=1895697)
- Bug 1893540 - Cannot clone a suspended VM (https://bugzilla.redhat.com/show_bug.cgi?id=1893540)

Also it is worth noting that the fix for "Cloning modal doesn't close automatically when cloning is finished/failed" bug won't be released in this version and 
there is no danger in closing the cloning modal manually anytime. (https://bugzilla.redhat.com/show_bug.cgi?id=1891303)

Comment 44 errata-xmlrpc 2020-11-24 13:12:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (RHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.3] 0-day), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5215


Note You need to log in before you can comment on or make changes to this bug.