Bug 1226622 - When cloning a VM from snapshot while the VM is up the "OK" button doesn't function
Summary: When cloning a VM from snapshot while the VM is up the "OK" button doesn't fu...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.6
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.6.0
Assignee: Martin Betak
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
Depends On:
Blocks: 1215845
TreeView+ depends on / blocked
 
Reported: 2015-05-31 08:27 UTC by lkuchlan
Modified: 2016-02-10 19:48 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-07 13:17:12 UTC
oVirt Team: Virt


Attachments (Terms of Use)
image+logs (679.20 KB, application/x-gzip)
2015-05-31 08:27 UTC, lkuchlan
no flags Details

Description lkuchlan 2015-05-31 08:27:47 UTC
Created attachment 1032767 [details]
image+logs

Description of problem:
When cloning a VM from snapshot while the VM is up the "OK" button doesn't function

Version-Release number of selected component (if applicable):
ovirt-engine-3.6.0-0.0.master.20150519172219.git9a2e2b3.el6.noarch
vdsm-4.17.0-822.git9b11a18.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a VM + disk and create a snapshot
2. Start the VM, wait for it to become 'Up'
3. Initiate Clone VM from snapshot from the VM snapshot. Try to confirm the creation (Click 'OK')

Actual results:
OK button doesn't function

Expected results:
OK button should function

Additional info:
Screenshot + logs

Comment 1 Allon Mureinik 2015-06-03 09:56:24 UTC
Michal, isn't this a virt feature?

Comment 2 Michal Skrivanek 2015-06-05 13:40:15 UTC
it is
should be part of 1177156

*** This bug has been marked as a duplicate of bug 1177156 ***

Comment 3 lkuchlan 2015-06-07 11:19:02 UTC
Michal, 
This bug has nothing to do with the RFE requested in bug 1177156. This bug is a regression in webadmin, the OK button doesn't function when cloning a VM from a snapshot of a running VM (this functionality is not new). Also, bug 1177156 refers to clone from a running VM and not from snapshot

Comment 4 Allon Mureinik 2015-06-07 13:00:46 UTC
(In reply to Michal Skrivanek from comment #2)
> it is
> should be part of 1177156
> 
> *** This bug has been marked as a duplicate of bug 1177156 ***

(In reply to lkuchlan from comment #3)
> Michal, 
> This bug has nothing to do with the RFE requested in bug 1177156. This bug
> is a regression in webadmin, the OK button doesn't function when cloning a
> VM from a snapshot of a running VM (this functionality is not new). Also,
> bug 1177156 refers to clone from a running VM and not from snapshot

Moving to virt based on comment 2.
I'll leave the analysis and reply to comment 3 to the relevant stakeholders.

Comment 5 Martin Betak 2015-07-07 13:17:12 UTC
I tried to reproduce the issue on current master and the button works successfully. This sorts of bugs (clicking on button having no effect) usually present themselves in the alpha phase. 

Please try with newer 3.6 build and if this issue is still present, reopen the bug.

Thanks,

Martin


Note You need to log in before you can comment on or make changes to this bug.