Bug 117738 - Calltrace occurs during boot for USB during startup
Calltrace occurs during boot for USB during startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-07 19:44 EST by Eric N. Ebert
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-21 14:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (424.73 KB, text/plain)
2004-03-10 17:14 EST, Eric N. Ebert
no flags Details

  None (edit)
Description Eric N. Ebert 2004-03-07 19:44:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040217 Epiphany/1.1.10

Description of problem:
The calltrace seems to occur most of the time when the system is
booted but not always. The output below was taken from
/var/log/messages. I have a 4 USB port PCI card and two onboard USB ports.



Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.242

How reproducible:
Sometimes

Steps to Reproduce:
1.Boot the system
2.
3.
    

Actual Results:  calltrace occurs

Expected Results:  USB should load

Additional info:

xwing kernel: hub 3-0:1.0: 3 ports detected
xwing kernel: ohci_hcd 0000:02:06.1: OHCI Host Controller
xwing kernel: ohci_hcd 0000:02:06.1: irq 193, pci mem 4289e000
xwing kernel: ohci_hcd 0000:02:06.1: new USB bus registered, assigned
bus number 4
xwing kernel: irq 193: nobody cared!
xwing kernel: Call Trace:
xwing kernel:  [<0210ecec>] __report_bad_irq+0x2b/0x67
xwing kernel:  [<0210ed84>] note_interrupt+0x43/0x66
xwing kernel:  [<0210f0d7>] do_IRQ+0x19c/0x224
xwing kernel:  [<0211d73f>] smp_apic_timer_interrupt+0x124/0x129
xwing kernel:  [<02118f71>] delay_pmtmr+0xb/0x13
xwing kernel:  [<021beb95>] __delay+0x9/0xa
xwing kernel:  [<428cc04c>] hc_start+0x18d/0x22f [ohci_hcd]
xwing kernel:  [<428cc46d>] ohci_pci_start+0x10e/0x142 [ohci_hcd]
xwing kernel:  [<4288e131>] usb_hcd_pci_probe+0x36c/0x385 [usbcore]
xwing kernel:  [<021991f5>] sysfs_create_link+0x10f/0x119
xwing kernel:  [<021c4109>] pci_device_probe_static+0x2a/0x3d
xwing kernel:  [<021c4137>] __pci_device_probe+0x1b/0x2c
xwing kernel:  [<021c4163>] pci_device_probe+0x1b/0x2d
xwing kernel:  [<0220d1f2>] bus_match+0x27/0x45
xwing kernel:  [<0220d2be>] driver_attach+0x37/0x6a
xwing kernel:  [<0220d4d5>] bus_add_driver+0x6b/0x83
xwing kernel:  [<021c42a8>] pci_register_driver+0x6b/0x87
xwing kernel:  [<42866042>] ohci_hcd_pci_init+0x42/0x49 [ohci_hcd]
xwing kernel:  [<0213da3c>] sys_init_module+0x14f/0x25f
xwing kernel:
xwing kernel: handlers:
xwing kernel: [<4288b3bf>] (usb_hcd_irq+0x0/0x4b [usbcore])
xwing kernel: [<4288b3bf>] (usb_hcd_irq+0x0/0x4b [usbcore])
xwing kernel: Disabling IRQ #193
xwing kernel: irq 185: nobody cared!
xwing kernel: Call Trace:
xwing kernel:  [<0210ecec>] __report_bad_irq+0x2b/0x67
xwing kernel:  [<0210ed84>] note_interrupt+0x43/0x66
xwing kernel:  [<0210f0d7>] do_IRQ+0x19c/0x224
xwing kernel:  [<0211d73f>] smp_apic_timer_interrupt+0x124/0x129
xwing kernel:  [<02118f71>] delay_pmtmr+0xb/0x13
xwing kernel:  [<021beb95>] __delay+0x9/0xa
xwing kernel:  [<428cc04c>] hc_start+0x18d/0x22f [ohci_hcd]
xwing kernel:  [<428cc46d>] ohci_pci_start+0x10e/0x142 [ohci_hcd]
xwing kernel:  [<4288e131>] usb_hcd_pci_probe+0x36c/0x385 [usbcore]
xwing kernel:  [<021991f5>] sysfs_create_link+0x10f/0x119
xwing kernel:  [<021c4109>] pci_device_probe_static+0x2a/0x3d
xwing kernel:  [<021c4137>] __pci_device_probe+0x1b/0x2c
xwing kernel:  [<021c4163>] pci_device_probe+0x1b/0x2d
xwing kernel:  [<0220d1f2>] bus_match+0x27/0x45
xwing kernel:  [<0220d2be>] driver_attach+0x37/0x6a
xwing kernel:  [<0220d4d5>] bus_add_driver+0x6b/0x83
xwing kernel:  [<021c42a8>] pci_register_driver+0x6b/0x87
xwing kernel:  [<42866042>] ohci_hcd_pci_init+0x42/0x49 [ohci_hcd]
xwing kernel:  [<0213da3c>] sys_init_module+0x14f/0x25f
xwing kernel:
xwing kernel: handlers:
xwing kernel: [<4288b3bf>] (usb_hcd_irq+0x0/0x4b [usbcore])
xwing kernel: Disabling IRQ #185
Comment 1 Pete Zaitcev 2004-03-10 12:27:31 EST
Punting this to the community for the moment. The code in
2.6.3-2.1.242 is 2.6.3-rc2, I unpacked and diffed it.

What kind of box is this? Please capture dmesg and add attach
it to the bug. Please DO NOT drop it into the comments box.
Comment 2 Eric N. Ebert 2004-03-10 17:14:13 EST
Created attachment 98446 [details]
/var/log/messages

I've attached my /var/log/messages file. All of the calltrace wierdness that I
had going on seems to have disappeared since I upgraded to the 246smp kernel
this morning. Is it possible that this bug and Bug#117739 were fixed by the
resolution of Bug#117710? I don't know I just thought I'd throw that out there.
Comment 3 Pete Zaitcev 2004-03-16 23:03:28 EST
If this is gone, please close.
Comment 4 Eric N. Ebert 2004-03-21 14:03:52 EST
I have been unable to reproduce this at all since 246.

Note You need to log in before you can comment on or make changes to this bug.