Bug 1177790 - [RFE][HC] - add parameters and default policies for data centers running hyper converged nodes to utilize images locality.
Summary: [RFE][HC] - add parameters and default policies for data centers running hype...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.3.0
: ---
Assignee: Doron Fediuck
QA Contact: Pavel Stehlik
URL:
Whiteboard:
: 1177791 (view as bug list)
Depends On: 1177791
Blocks: HC_Host_4.0
TreeView+ depends on / blocked
 
Reported: 2014-12-30 12:24 UTC by Yaniv Lavi
Modified: 2019-04-28 14:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1177791 (view as bug list)
Environment:
Last Closed: 2018-02-18 16:25:46 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.3?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

Description Yaniv Lavi 2014-12-30 12:24:57 UTC
Description of problem:
Locality improves VMs performance. This feature is to add parameters and policies to oVirt scheduler to optimize VMs performance on hyper converged nodes.

This includes:
1. scheduling of disk creation in the best order for running VMs.
2. scheduling of the VM tun based on disk locality.
3. Get image replica set that is needed for scheduler.
4. Force image on a replica set in order to provide the best performance.

Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 10:52:20 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Doron Fediuck 2016-03-21 11:21:10 UTC
*** Bug 1177791 has been marked as a duplicate of this bug. ***

Comment 3 Red Hat Bugzilla Rules Engine 2017-07-14 09:47:17 UTC
This request has been proposed for two releases. This is invalid flag usage. The ovirt-future release flag has been cleared. If you wish to change the release flag, you must clear one release flag and then set the other release flag to ?.


Note You need to log in before you can comment on or make changes to this bug.