Bug 1177791 - [RFE][HC] - add parameters and default policies for data centers running hyper converged nodes to utilize images locality.
Summary: [RFE][HC] - add parameters and default policies for data centers running hype...
Keywords:
Status: CLOSED DUPLICATE of bug 1177790
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks: 1177790 HC_Host_4.0
TreeView+ depends on / blocked
 
Reported: 2014-12-30 12:25 UTC by Yaniv Lavi
Modified: 2016-03-21 11:21 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1177790
Environment:
Last Closed: 2016-03-21 11:21:10 UTC
oVirt Team: SLA
ylavi: ovirt-4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

Description Yaniv Lavi 2014-12-30 12:25:48 UTC
+++ This bug was initially created as a clone of Bug #1177790 +++

Description of problem:
Locality improves VMs performance. This feature is to add parameters and policies to oVirt scheduler to optimize VMs performance on hyper converged nodes.

This includes:
1. scheduling of disk creation in the best order for running VMs.
2. scheduling of the VM tun based on disk locality.
3. Get image replica set that is needed for scheduler.
4. Force image on a replica set in order to provide the best performance.

Comment 1 Niels de Vos 2015-01-06 13:19:55 UTC
It is possible to get the bricks (and therefore servers) where the image (file) is located. There is an extended attribute that can be read by privileged processes to retrieve it.

It is also possible with some special notation (appending a @<something> to the filename?) to force creation of the file on a specific sub-volume (replica set).

The DHT/distribute folks can probably explain the details.

Comment 2 Doron Fediuck 2015-08-26 14:12:54 UTC
Since this is about ovirt scheduler, updating relevant components.

Comment 3 Red Hat Bugzilla Rules Engine 2015-10-19 11:01:54 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Doron Fediuck 2016-03-21 11:21:10 UTC

*** This bug has been marked as a duplicate of bug 1177790 ***


Note You need to log in before you can comment on or make changes to this bug.