Bug 117780 - kernel panic in i810_dma_dispatch_vertex
kernel panic in i810_dma_dispatch_vertex
Status: CLOSED DUPLICATE of bug 117713
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 09:39 EST by Michael Young
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2004-03-08 09:39:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
I get the crash below with the 2.6.3-2.* kernels, when X is left idle
for a few minutes. The display freezes black, typing at the keyboard
doesn't seem to do anything, but you can still connect to the machine
remotely.
This wasn't in the 2.6.3-1.* or earlier FC2t1 kernels, but I believe
it has been in arjan's kernels for some time.

Mar  8 13:17:54 itspc114 kernel: Unable to handle kernel paging
request at virtual address f605a000
Mar  8 13:17:54 itspc114 kernel:  printing eip:
Mar  8 13:17:54 itspc114 kernel: 12a8acd5
Mar  8 13:17:54 itspc114 kernel: *pde = 00000000
Mar  8 13:17:54 itspc114 kernel: Debug: sleeping function called from
invalid context at include/linux/rwsem.h:43
Mar  8 13:17:54 itspc114 kernel: in_atomic():0, irqs_disabled():1
Mar  8 13:17:54 itspc114 kernel: Call Trace:
Mar  8 13:17:54 itspc114 kernel:  [<021250a3>] __might_sleep+0x80/0x8a
Mar  8 13:17:54 itspc114 kernel:  [<02166287>] rw_vm+0x1b7/0x3aa
Mar  8 13:17:54 itspc114 kernel:  [<0212842f>]
__call_console_drivers+0x36/0x42
Mar  8 13:17:54 itspc114 kernel:  [<12a8acd5>]
i810_dma_dispatch_vertex+0xd5/0x2e0 [i810]
Mar  8 13:17:54 itspc114 kernel:  [<12a8acd5>]
i810_dma_dispatch_vertex+0xd5/0x2e0 [i810]
Mar  8 13:17:54 itspc114 kernel:  [<021666d3>] get_user_size+0x30/0x57
Mar  8 13:17:54 itspc114 kernel:  [<12a8acd5>]
i810_dma_dispatch_vertex+0xd5/0x2e0 [i810]
Mar  8 13:17:54 itspc114 kernel:  [<0210e0cf>] handle_BUG+0x32/0xdf
Mar  8 13:17:54 itspc114 kernel:  [<0212883a>] printk+0x26a/0x2e3
Mar  8 13:17:54 itspc114 kernel:  [<0210e23d>] die+0xc1/0x1b1
Mar  8 13:17:54 itspc114 kernel:  [<021203c7>] do_page_fault+0x2f8/0x447
Mar  8 13:17:54 itspc114 kernel:  [<12a8acd5>]
i810_dma_dispatch_vertex+0xd5/0x2e0 [i810]
Mar  8 13:17:54 itspc114 kernel:  [<021c2885>] inode_has_perm+0x57/0x5f
Mar  8 13:17:54 itspc114 kernel:  [<02159211>] vma_link+0xc3/0x14c
Mar  8 13:17:54 itspc114 kernel:  [<021200cf>] do_page_fault+0x0/0x447
Mar  8 13:17:54 itspc114 kernel:  [<12a8acd5>]
i810_dma_dispatch_vertex+0xd5/0x2e0 [i810]
Mar  8 13:17:54 itspc114 kernel:  [<12a8b31f>]
i810_dma_vertex+0xbb/0xee [i810]
Mar  8 13:17:54 itspc114 kernel:  [<12a86dff>] i810_ioctl+0xe3/0xef [i810]
Mar  8 13:17:54 itspc114 kernel:  [<12a8b264>]
i810_dma_vertex+0x0/0xee [i810]
Mar  8 13:17:54 itspc114 kernel:  [<0217d27f>] sys_ioctl+0x2a0/0x341
Mar  8 13:17:54 itspc114 kernel:
Mar  8 13:17:54 itspc114 kernel: Oops: 0002 [#1]
Mar  8 13:17:54 itspc114 kernel: CPU:    0
Mar  8 13:17:54 itspc114 kernel: EIP:    0060:[<12a8acd5>]    Not tainted
Mar  8 13:17:54 itspc114 kernel: EFLAGS: 00210202   (2.6.3-2.1.242)
Mar  8 13:17:54 itspc114 kernel: EIP is at
i810_dma_dispatch_vertex+0xd5/0x2e0 [i810]
Mar  8 13:17:54 itspc114 kernel: eax: 7f040067   ebx: 00000004   ecx:
f605a000  edx: 00000000
Mar  8 13:17:54 itspc114 kernel: esi: 0abf0000   edi: 100e3e20   ebp:
000001a4  esp: 0dd5ef10
Mar  8 13:17:54 itspc114 kernel: ds: 007b   es: 007b   ss: 0068
Mar  8 13:17:54 itspc114 kernel: Process gltext (pid: 1681,
threadinfo=0dd5e000 task=0fe6c080)
Mar  8 13:17:54 itspc114 kernel: Stack: 00000069 7f040067 00000000
006ff000 00000001 12a06958 0bca6838 00000001
Mar  8 13:17:54 itspc114 kernel:        11805d28 11805d28 100e3e20
0bc3e000 12a06898 12a8b31f 000001a4 0ac14000
Mar  8 13:17:54 itspc114 kernel:        00000000 000001a4 00000001
00000001 11805d28 0ccdb52c 12a905ec 400c6441
Mar  8 13:17:54 itspc114 kernel: Call Trace:
Mar  8 13:17:54 itspc114 kernel:  [<12a8b31f>]
i810_dma_vertex+0xbb/0xee [i810]
Mar  8 13:17:54 itspc114 kernel:  [<12a86dff>] i810_ioctl+0xe3/0xef [i810]
Mar  8 13:17:54 itspc114 kernel:  [<12a8b264>]
i810_dma_vertex+0x0/0xee [i810]
Mar  8 13:17:54 itspc114 kernel:  [<0217d27f>] sys_ioctl+0x2a0/0x341
Mar  8 13:17:54 itspc114 kernel:
Mar  8 13:17:54 itspc114 kernel: Code: 89 01 74 12 8b 54 24 18 8b 42
0c c7 44 05 00 00 00 00 00 83
Comment 1 Michael Young 2004-03-08 09:53:03 EST
Actually, this could be the same issue as bug 117713 .
Comment 2 Bill Nottingham 2004-03-08 15:32:08 EST

*** This bug has been marked as a duplicate of 117713 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.