Bug 117713 - (i830drm) i830 DRM assert in 2.6.3-2.1.242
i830 DRM assert in 2.6.3-2.1.242
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
: 117642 117780 118527 119301 119496 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-07 16:34 EST by James Mitchell Ullman
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 23:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant output from /var/log/messages (3.43 KB, text/plain)
2004-03-07 16:35 EST, James Mitchell Ullman
no flags Details

  None (edit)
Description James Mitchell Ullman 2004-03-07 16:34:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
When I boot to either of these kernels, everything else I have tested
has worked.  However, if I attempt to lock the screen within X, the
screen blacks and input is no longer accepted.  I can get the machine
to safely shutdown by tapping the power button once.

The last kernel to work properly was kernel-smp-2.6.3-1.118.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.3-2.1.240 and kernel-smp-2.6.3-2.1.242

How reproducible:
Always

Steps to Reproduce:
1.Boot to either of the kernels shown
2.Log into X
3.Lock the screen from the menu
    

Actual Results:  Monitor blacks out, and all terminal input is rejected.

Expected Results:  Usual screen locking ie: xscreensaver starting
properly.

Additional info:

Motherboard: Intel D865GBFLK
Proccessor: Intel Pentium 4 C 2.8Ghz (Hyper Threading enabled in BIOS)
Ram: 512MB GEIL DDR in Dual Channel Mode
Video: Onboard Intel Extreme 2(which does have a bug in X regarding
the refresh rate a patch exists but has not been committed)
Comment 1 James Mitchell Ullman 2004-03-07 16:35:38 EST
Created attachment 98362 [details]
Relevant output from /var/log/messages
Comment 2 Arjan van de Ven 2004-03-07 17:50:26 EST
Mar  7 16:22:24 snore kernel:  [<21904099>]
i830_dma_dispatch_vertex+0x1c2/0x469 [i830]
Mar  7 16:22:24 snore kernel:  [<021fb665>] vt_console_print+0x0/0x289
Mar  7 16:22:24 snore kernel:  [<21904099>]
i830_dma_dispatch_vertex+0x1c2/0x469 [i830]
Mar  7 16:22:24 snore kernel:  [<0215fa07>] get_user_size+0x2e/0x55
Mar  7 16:22:24 snore kernel:  [<21904099>]
i830_dma_dispatch_vertex+0x1c2/0x469 [i830]
Mar  7 16:22:24 snore kernel:  [<0210dc12>] handle_BUG+0x32/0xdf
Mar  7 16:22:24 snore kernel:  [<0210dd23>] die+0x64/0x124
Mar  7 16:22:24 snore kernel:  [<02120501>] do_page_fault+0x2fe/0x4b5
Mar  7 16:22:24 snore kernel:  [<21904099>]
i830_dma_dispatch_vertex+0x1c2/0x469 [i830]
Mar  7 16:22:24 snore kernel:  [<021ae572>] avc_has_perm+0x3f/0x49
Mar  7 16:22:24 snore kernel:  [<021af8e8>] inode_has_perm+0x57/0x5f
Mar  7 16:22:24 snore kernel:  [<02120203>] do_page_fault+0x0/0x4b5
Mar  7 16:22:24 snore kernel:  [<21904099>]
i830_dma_dispatch_vertex+0x1c2/0x469 [i830]
Mar  7 16:22:24 snore kernel:  [<2190463b>] i830_dma_vertex+0xbb/0xdf
[i830]
Mar  7 16:22:24 snore kernel:  [<218ff850>] i830_ioctl+0xe5/0xf2 [i830]
Mar  7 16:22:24 snore kernel:  [<21904580>] i830_dma_vertex+0x0/0xdf
[i830]
Mar  7 16:22:24 snore kernel:  [<02173545>] sys_ioctl+0x243/0x2a6
Comment 3 Bill Nottingham 2004-03-08 15:32:12 EST
*** Bug 117780 has been marked as a duplicate of this bug. ***
Comment 4 Sahil Verma 2004-03-16 14:45:18 EST
Is this a dupe of 117642?

EIP is almost at the same place: i830_dma_dispatch_vertex+0x1c2/0x469
in both cases.
Comment 5 Michael Young 2004-03-16 15:20:05 EST
It certainly sounds the similar enough to be the same issue.
Comment 6 Bill Nottingham 2004-03-18 00:50:19 EST
*** Bug 117642 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2004-03-18 00:50:28 EST
*** Bug 118527 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2004-03-18 00:51:15 EST
i830+ DRM and 4/4 split do *not* get along; they've never worked together.
Comment 9 Arjan van de Ven 2004-03-23 11:38:52 EST
I just found + fixed a bug in this specific function that perfectly
explains the oops;
the kernel with the fix is available from
http://people.redhat.com/arjanv/2.6/

Comment 10 Michael Young 2004-03-23 12:17:16 EST
I still have Problems with the i810 driver, it freezes when I try the
glblur screensaver, there are errors like
Mar 23 17:11:17 itspc114 kernel: [drm:i810_wait_ring] *ERROR* space:
65300 wanted 65528
Mar 23 17:11:17 itspc114 kernel: [drm:i810_wait_ring] *ERROR* lockup
Mar 23 17:11:22 itspc114 kernel: [drm:i810_wait_ring] *ERROR* space:
65284 wanted 65528
Mar 23 17:11:22 itspc114 kernel: [drm:i810_wait_ring] *ERROR* lockup
Mar 23 17:13:51 itspc114 kernel: [drm:i810_wait_ring] *ERROR* space:
65276 wanted 65528
Mar 23 17:13:51 itspc114 kernel: [drm:i810_wait_ring] *ERROR* lockup
in /var/log/messages, and
Error in I810WaitLpRing(), now is 88290, start is 86289
pgetbl_ctl: 0xfd10001 pgetbl_err: 0x0
ipeir: 4 iphdr: 3f5f56ef
LP ring tail: 3db0 head: 3cc4 len: f001 start 580000
eir: 0 esr: 1 emr: 3d
instdone: ff72 instpm: 0
memmode: 24 instps: 830
hwstam: 9ac7 ier: 0 imr: 9ac7 iir: 0
space: 65292 wanted 65528
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0x129d7000 at 0xf6ef1000

Fatal server error:
lockup
in /var/log/XFree86.0.log
This is with xorg-x11-0.0.6.6-0.0.2004_03_11.6 and kernel-2.6.4-1.286
Comment 11 Arjan van de Ven 2004-03-23 12:29:00 EST
THAT is an entirely different matter and maybe an X bug (most likely
actually)
Comment 12 Brian Millett 2004-03-23 21:25:06 EST
Well, I get the same error as Michael Young's X errors.  
I've updated/installed the xorg packages so I can not say what will
happen with the "old" XFree86 packages.

Should this be a different bugzilla notice?
Comment 13 Bill Nottingham 2004-03-29 16:43:51 EST
*** Bug 119301 has been marked as a duplicate of this bug. ***
Comment 14 Bill Nottingham 2004-03-30 17:38:50 EST
*** Bug 119496 has been marked as a duplicate of this bug. ***
Comment 15 Manuel "Chilli" Chakravarty 2004-04-07 07:58:17 EDT
FYI, the subsequent problem in "drm:i810_wait_ring" has been reported
as #119705 for the xorg-x11 component.
Comment 16 jan p. springer 2004-04-20 07:28:27 EDT
small success message. i'm running w/ 2.6.5-1.326 and found
explanations on the web wrt. mtrr and dri. turns out that the 4MB mtrr
setup done by the vesafb driver cannot be reused/changed by the
x-server. fix is to manually disable this segment (echo "disable=06" >
/proc/mtrr; 06 is the segment number on my machine) before starting
the x-server. i can enable dri in the xconfig and see accelerated gfx.
only downside is that the x-server (esp. the i810 videodrv) generates
oopses on restart randomly. i can provide the log entries but a
feeling tells me this will go away with newer x11 versions.
Comment 17 Mike A. Harris 2004-05-05 11:47:54 EDT
The latest rawhide kernel has i8xx DRM fixes which are believed
may resolve this issue.  Details can be found in bug #119311.  Please
test Fedora Core 2 test3 fully updated with the latest rawhide updates,
and see if the problem is resolved for you with this new kernel or not.

Setting bug status to "MODIFIED" pending user testing.  Please change
status to "RAWHIDE" if the problem is resolved now, or back to
"ASSIGNED" if it persists.
Comment 18 Brian Millett 2004-05-05 12:54:55 EDT
Thank you.  The glx xscreensaver modules now work for my toshiba laptop.

Good work.
Comment 19 Michael Young 2004-05-05 13:17:03 EDT
Works for me too. With the -349 kernel the GLblur screen saver causes
a hang but it works with the -350 kernel.
Comment 20 Jens Petersen 2004-05-06 03:00:38 EDT
Yay, -350 seems to be working well here too. :-)
Comment 21 Daniel Pereda 2004-05-25 21:19:02 EDT
I still have Problems with the i810 driver :(, it freezes when I try
to run tuxracer or quake 3. I had the same error that Michael Young in
the COmment 10. I'm running on Fedora COre 2 final (Kernel
2.6.5-1.358) on a P3 with a i810 motherboard. 
thx for any help..

Note You need to log in before you can comment on or make changes to this bug.