Bug 1177901 - Allow sync-plan to change sync-date in WebUI
Summary: Allow sync-plan to change sync-date in WebUI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.6
Hardware: All
OS: Linux
low
medium vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1195836 (view as bug list)
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-12-31 07:42 UTC by Pavel Moravec
Modified: 2019-07-11 08:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 13:58:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
sync plan edit next sync (86.16 KB, image/png)
2015-04-24 10:26 UTC, Tazim Kolhar
no flags Details
sync plan edit next sync (87.81 KB, image/png)
2015-04-27 09:50 UTC, Tazim Kolhar
no flags Details

Description Pavel Moravec 2014-12-31 07:42:14 UTC
Description of problem:
Once I create a sync plan in Web UI, I can't change "Next Sync" / sync-date there. So I can't apply changes like "let synchronize with CDN at 3am, not at 5am every day".

As hammer CLI allows that change via sync-plan update --sync-date option, it is just WebUI lacking the ability to edit.


Version-Release number of selected component (if applicable):
Satellite 6.0.6


How reproducible:
100%


Steps to Reproduce:
1. Create a sync plan via WebUI
2. Try to edit it.


Actual results:
You can change Name, Description and Interval, but not either Start Date or Next Sync.


Expected results:
You can change Name, Description, Interval and also Next Sync.
Once the Next Sync is changed, the next synchronization is really executed at that time and not at the original time.


Additional info:
Workaround: use hammer CLI.

Comment 2 Peter Vreman 2015-03-02 13:19:59 UTC
*** Bug 1195836 has been marked as a duplicate of this bug. ***

Comment 4 Walden Raines 2015-04-14 17:52:12 UTC
Created redmine issue http://projects.theforeman.org/issues/10140 from this bug

Comment 5 Walden Raines 2015-04-14 20:32:46 UTC
PR: https://github.com/Katello/katello/pull/5177

Comment 6 Bryan Kearney 2015-04-15 12:05:28 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10140 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|f614d6b6ef23dac73580c46ddbb13ab9cc48ef77.

Comment 8 Tazim Kolhar 2015-04-24 10:25:32 UTC
FAILEDQA:

# rpm -qa | grep foreman
foreman-libvirt-1.7.2.17-1.el6_6sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.10-1.el6_6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el6_6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.3-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.5-1.el6_6sat.noarch
foreman-postgresql-1.7.2.17-1.el6_6sat.noarch
foreman-debug-1.7.2.17-1.el6_6sat.noarch
foreman-1.7.2.17-1.el6_6sat.noarch
foreman-ovirt-1.7.2.17-1.el6_6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.3-1.el6_6sat.noarch
foreman-proxy-1.7.2.4-1.el6_6sat.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-client-1.0-1.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-selinux-1.7.2.13-1.el6_6sat.noarch
rubygem-hammer_cli_foreman-0.1.4.9-1.el6_6sat.noarch
foreman-compute-1.7.2.17-1.el6_6sat.noarch
foreman-vmware-1.7.2.17-1.el6_6sat.noarch
ruby193-rubygem-foreman-redhat_access-0.1.0-1.el6_6sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el6_6sat.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-proxy-1.0-2.noarch
ruby193-rubygem-foreman_docker-1.2.0.9-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.7-1.el6_6sat.noarch
foreman-gce-1.7.2.17-1.el6_6sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.9-1.el6_6sat.noarch

steps:
1. Create a sync plan via WebUI
2. Try to edit it.

screenshot attached

Comment 9 Tazim Kolhar 2015-04-24 10:26:03 UTC
Created attachment 1018373 [details]
sync plan edit next sync

Comment 10 Walden Raines 2015-04-24 13:46:56 UTC
Nothing for me to do here, not sure why this didn't make it in the latest build.  It seems to have been cherry-picked correctly into the 6.1 repo.

Comment 11 Mike McCune 2015-04-24 19:10:21 UTC
This was due to SNAP1 missing the build of katello, back ON_QA now. Sorry for the time waste.

Comment 12 Tazim Kolhar 2015-04-27 09:49:58 UTC
VERIFIED :

# rpm -qa | grep foreman
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.9-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.3-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.3-1.el7sat.noarch
foreman-debug-1.7.2.17-1.el7sat.noarch
foreman-libvirt-1.7.2.17-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.10-1.el7sat.noarch
foreman-compute-1.7.2.17-1.el7sat.noarch
foreman-ovirt-1.7.2.17-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.5-1.el7sat.noarch
foreman-postgresql-1.7.2.17-1.el7sat.noarch
qe-sat6-rhel71.usersys.redhat.com-foreman-client-1.0-1.noarch
qe-sat6-rhel71.usersys.redhat.com-foreman-proxy-1.0-1.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-1.7.2.17-1.el7sat.noarch
foreman-gce-1.7.2.17-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.9-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.9-1.el7sat.noarch
foreman-vmware-1.7.2.17-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.7-1.el7sat.noarch
foreman-proxy-1.7.2.4-1.el7sat.noarch
qe-sat6-rhel71.usersys.redhat.com-foreman-proxy-client-1.0-1.noarch
ruby193-rubygem-foreman-redhat_access-0.1.0-1.el7sat.noarch

steps
1. Create a sync plan via WebUI
2. Try to edit it.


screenshot attached

Comment 13 Tazim Kolhar 2015-04-27 09:50:21 UTC
Created attachment 1019285 [details]
sync plan edit next sync

Comment 14 Bryan Kearney 2015-08-11 13:23:49 UTC
This bug is slated to be released with Satellite 6.1.

Comment 15 Bryan Kearney 2015-08-12 13:58:43 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.