Bug 1178064 - [abrt] python-boto: auth.py:975:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials
[abrt] python-boto: auth.py:975:get_auth_handler:NoAuthHandlerFound: No handl...
Status: CLOSED DUPLICATE of bug 821799
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
21
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:40b600d475f7a47cf505422e582...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-01 19:00 EST by Rubén Lledó
Modified: 2015-04-08 21:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-08 21:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.46 KB, text/plain)
2015-01-01 19:00 EST, Rubén Lledó
no flags Details
File: environ (2.07 KB, text/plain)
2015-01-01 19:00 EST, Rubén Lledó
no flags Details

  None (edit)
Description Rubén Lledó 2015-01-01 19:00:35 EST
Version-Release number of selected component:
python-boto-2.34.0-4.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python2 /bin/asadmin start-domain
executable:     /bin/asadmin
kernel:         3.17.7-300.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
auth.py:975:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials

Traceback (most recent call last):
  File "/bin/asadmin", line 260, in <module>
    autoscale = boto.connect_autoscale()
  File "/usr/lib/python2.7/site-packages/boto/__init__.py", line 208, in connect_autoscale
    **kwargs)
  File "/usr/lib/python2.7/site-packages/boto/ec2/autoscale/__init__.py", line 115, in __init__
    profile_name=profile_name)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 1096, in __init__
    profile_name=profile_name)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 569, in __init__
    host, config, self.provider, self._required_auth_capability())
  File "/usr/lib/python2.7/site-packages/boto/auth.py", line 975, in get_auth_handler
    'Check your credentials' % (len(names), str(names)))
NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials

Local variables in innermost frame:
checked_handlers: [<class 'boto.auth.HmacAuthV4Handler'>]
provider: <boto.provider.Provider object at 0x7f1cfc853ed0>
host: 'autoscaling.us-east-1.amazonaws.com'
handler: <class 'boto.auth.HmacAuthV4Handler'>
names: ['HmacAuthV4Handler']
ready_handlers: []
requested_capability: ['hmac-v4']
auth_handlers: [<class 'boto.auth.HmacAuthV4Handler'>]
config: <boto.pyami.config.Config instance at 0x7f1cfce094d0>
Comment 1 Rubén Lledó 2015-01-01 19:00:38 EST
Created attachment 975119 [details]
File: backtrace
Comment 2 Rubén Lledó 2015-01-01 19:00:39 EST
Created attachment 975120 [details]
File: environ
Comment 3 Garrett Holmstrom 2015-04-08 21:37:52 EDT

*** This bug has been marked as a duplicate of bug 821799 ***

Note You need to log in before you can comment on or make changes to this bug.