Bug 117811 - CD install of version 8 to two HDD system fails half way through whichever HDD is chosen to install to.
CD install of version 8 to two HDD system fails half way through whichever HD...
Status: CLOSED DUPLICATE of bug 75377
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 16:02 EST by Bart
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart 2004-03-08 16:02:15 EST
Description of problem:

Got version 8.0 on three CD's with a book.
checked media were OK.

Have a 9 GB and 2.45 GB HDD's 

Disk druid and whatever other method e.g. f disk has no problem 
seeing the HDD's. Symptome of what follows happens whichever disk I 
try to install to and whether I pick a minimum (400 Meg ) install or 
maximum install (4.5 GB I believe)or any option in between.

Installs image to HDD and starts to install packages. I will give 
example of Personal Desktop install i.e 1601MB

Gets about half way through (or on larger installs gets to second CD)
Then anaconda crashes (partial dump details below) 


Version-Release number of selected component (if applicable):

Red Hat Linux version 8

How reproducible: Happens no matter which install I select.


Additional info:

Screen gives following message 
partial dump follows - 20 lines of text 

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in 
renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 719, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 283, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 119, in getFilename
    f = open("/mnt/source/.discinfo")
IOError: [Errno 2] No such file or directory: '/mnt/source/.discinfo'

[snipped rest of logfile]
Comment 1 Jeremy Katz 2004-03-08 18:18:31 EST

*** This bug has been marked as a duplicate of 75377 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.