Bug 117846 - rc.sysinit from initscripts could not set netprofile
rc.sysinit from initscripts could not set netprofile
Status: CLOSED DUPLICATE of bug 117838
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-09 03:52 EST by Thomas Bittermann
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes bug #117846 (611 bytes, patch)
2004-03-09 03:53 EST, Thomas Bittermann
no flags Details | Diff

  None (edit)
Description Thomas Bittermann 2004-03-09 03:52:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:
The package redhat-config-network recently changed it's name to
system-config-network. Since then there's no more
redhat-config-network-cmd around, but this command is still used in
/etc/rc.d/rc.sysinit which is part of the initscripts.

Because of this, the selected netprofile could not be set in
/etc/rc.d/rc.sysinit. A (fixing) patch is appended.

Version-Release number of selected component (if applicable):
initscripts-7.46-1.1

How reproducible:
Always

Steps to Reproduce:
1. Choose a (different) netprofile via kernel cmd param "netprofile=xxx".
2. After startup you will see the system is still using the old profile.
3. Simply take a look at the patch ... ;-)
    

Actual Results:  /etc/rc.d/rc.sysinit does not change the netprofile.

Expected Results:  /etc/rc.d/rc.sysinit should change the netprofile
to the selected (kernel cmd param) one.

Additional info:
Comment 1 Thomas Bittermann 2004-03-09 03:53:12 EST
Created attachment 98394 [details]
fixes bug #117846
Comment 2 Bill Nottingham 2004-03-09 14:08:26 EST

*** This bug has been marked as a duplicate of 117838 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.