Bug 117910 - system-config-soundcard doesn't start "list.index(x): x not in list"
system-config-soundcard doesn't start "list.index(x): x not in list"
Status: CLOSED DUPLICATE of bug 115198
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-09 16:33 EST by Toni Willberg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2004-03-09 16:33:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040217 Epiphany/1.1.9

Description of problem:
system-config-soundcard-1.2.5-1
fedora-release-1.90-11


Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.5-1

How reproducible:
Always

Steps to Reproduce:
1. system-config-soundcard


Actual Results:  # system-config-soundcard
 
(system-config-soundcard.py:7396): Gdk-WARNING **: DESKTOP_STARTUP_ID
contains invalid UTF-8
Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
47, in ?
    app = soundcard.childWindow()
  File "/usr_share/system-config-soundcard/soundcard.py", line 160, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list


Additional info:

Earlier versions had the same problem.
Comment 1 Toni Willberg 2004-03-09 17:23:19 EST
commenting out this line fixes the problem:
 soundcard.py.160:
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))

It seems that self.soundcardBackend.getDefaultCard() returns "None"
for me, and this causes the problem. Should add some if block around
that .set_active call.

Additionally the default device info isn't saved anywhere. If I change
it from the UI and click OK, on next run .getDefaultCard() gives still
"None".

I don't know Python and was unable to provide a working patch. :)
Comment 2 Toni Willberg 2004-03-09 18:09:32 EST

*** This bug has been marked as a duplicate of 115198 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.