Bug 1179195 - [RFE][engine-backend][HC] - add the possibility to import an existing Gluster and POSIXFS export domains
Summary: [RFE][engine-backend][HC] - add the possibility to import an existing Gluster...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: 3.5.2
Assignee: Tal Nisan
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On:
Blocks: 1160731 Generic_Hyper_Converged_Host 1193058
TreeView+ depends on / blocked
 
Reported: 2015-01-06 12:23 UTC by Yaniv Lavi
Modified: 2016-02-10 19:43 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1160731
Environment:
Last Closed: 2015-04-29 06:19:20 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 37282 0 None None None Never
oVirt gerrit 37291 0 None None None Never
oVirt gerrit 37341 0 ovirt-engine-3.5 MERGED restapi: Allow import of Posix/Gluster export storage domains Never
oVirt gerrit 37342 0 ovirt-engine-3.5 MERGED webadmin: Allow import of Posix/Gluster export storage domains Never

Description Yaniv Lavi 2015-01-06 12:23:30 UTC
+++ This bug was initially created as a clone of Bug #1160731 +++

Description of problem:
There should be an option to import an existing Gluster and POSIXFS export domains. 
The Gluster and POSIXFS export domains support was introduced in rhev 3.5, but it missing the option to import such domains to the DC. 

Tested on webadmin

Version-Release number of selected component (if applicable):
rhev 3.5 vt8

--- Additional comment from Allon Mureinik on 2014-11-10 09:45:16 EST ---

Maor, why is different than any other file domain? Is this just a UI gap?

--- Additional comment from Maor on 2014-11-10 10:17:01 EST ---

(In reply to Allon Mureinik from comment #1)
> Maor, why is different than any other file domain? Is this just a UI gap?

no,
we might also need to change HSMGetStorageDomainsListVDSCommand, since it passes the storage type and in VDSM it filters it.
Since in the engine the only API we support has storage type then we might need to change this also.

--- Additional comment from Itamar Heim on 2014-11-20 21:48:08 EST ---

federico - this and iso domain for gluster are worth tracking for hyper-converged

--- Additional comment from Elad on 2014-11-23 04:26:36 EST ---

Steps to reproduce:
1. Click on 'import domain', export/gluster and export/posixfs are not available

--- Additional comment from Allon Mureinik on 2014-11-23 08:35:29 EST ---

Talked to Maor F2F, and this indeed seems to be a trivial GUI gap.
Amit - can you handle it please?

Comment 1 Eyal Edri 2015-03-22 14:24:03 UTC
bug fixed 7 weeks ago, should be in vt14.

Comment 2 Ori Gofen 2015-03-26 17:56:21 UTC
verified with vt14.1 build, works via UI+rest

Comment 3 Eyal Edri 2015-04-29 06:19:20 UTC
ovirt 3.5.2 was GA'd. closing current release.


Note You need to log in before you can comment on or make changes to this bug.