Bug 1160731 - [RFE][engine-backend][HC] - add the possibility to import existing Gluster and POSIXFS export domains
Summary: [RFE][engine-backend][HC] - add the possibility to import existing Gluster an...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Tal Nisan
QA Contact: Elad
URL:
Whiteboard:
Depends On: 1179195
Blocks: 1186375
TreeView+ depends on / blocked
 
Reported: 2014-11-05 14:03 UTC by Elad
Modified: 2016-03-09 20:50 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, it was only possible to import NFS export domains. Now, it is possible to import Gluster and PosixFS export domains, as well as, NFS export domains.
Clone Of:
: 1179195 1186375 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:50:39 UTC
oVirt Team: Storage
ylavi: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 37282 master MERGED webadmin: Allow import of Posix/Gluster export storage domains Never
oVirt gerrit 37291 master MERGED restapi: Allow import of Posix/Gluster export storage domains Never
oVirt gerrit 37341 ovirt-engine-3.5 MERGED restapi: Allow import of Posix/Gluster export storage domains Never

Description Elad 2014-11-05 14:03:52 UTC
Description of problem:
There should be an option to import an existing Gluster and POSIXFS export domains. 
The Gluster and POSIXFS export domains support was introduced in rhev 3.5, but it missing the option to import such domains to the DC. 

Tested on webadmin

Version-Release number of selected component (if applicable):
rhev 3.5 vt8

Comment 1 Allon Mureinik 2014-11-10 14:45:16 UTC
Maor, why is different than any other file domain? Is this just a UI gap?

Comment 2 Maor 2014-11-10 15:17:01 UTC
(In reply to Allon Mureinik from comment #1)
> Maor, why is different than any other file domain? Is this just a UI gap?

no,
we might also need to change HSMGetStorageDomainsListVDSCommand, since it passes the storage type and in VDSM it filters it.
Since in the engine the only API we support has storage type then we might need to change this also.

Comment 3 Itamar Heim 2014-11-21 02:48:08 UTC
federico - this and iso domain for gluster are worth tracking for hyper-converged

Comment 4 Elad 2014-11-23 09:26:36 UTC
Steps to reproduce:
1. Click on 'import domain', export/gluster and export/posixfs are not available

Comment 5 Allon Mureinik 2014-11-23 13:35:29 UTC
Talked to Maor F2F, and this indeed seems to be a trivial GUI gap.
Amit - can you handle it please?

Comment 6 Federico Simoncelli 2015-01-06 14:07:48 UTC
Removing needinfo (the bz has been added to the hc tracker).

Comment 8 Allon Mureinik 2015-01-27 21:29:47 UTC
patch 37291 is still not merged - is the MODIFIED status a mistake, or am I overlooking something?

Comment 9 Elad 2015-05-13 14:31:03 UTC
Tested import domain for export/Gluster and export/POSIXFS domains. Passed.
Used ovirt-3.6.0-1.

Comment 12 errata-xmlrpc 2016-03-09 20:50:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.