Bug 117932 - gok segfaults on startup
Summary: gok segfaults on startup
Status: CLOSED DUPLICATE of bug 118504
Alias: None
Product: Fedora
Classification: Fedora
Component: gok   
(Show other bugs)
Version: rawhide
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-10 07:16 UTC by neil v. patel
Modified: 2013-04-02 04:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description neil v. patel 2004-03-10 07:16:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
MyIE2; .NET CLR 1.1.4322)

Description of problem:
i can't run gok. when i do so from a command prompt, i get the 
following:

3 event types available
login mode = false
Word prediction dictionary contains a total of 3000 words
Segmentation fault

a small window is drawn briefly sometime before the segfault.

i'm using FC2, test 1, fully up2dated, and then updated manually with 
openssl, openssl-devel and switchdesk (which don't seem to come down 
by up2date...)

any thoughts?

[n]

Version-Release number of selected component (if applicable):
0.9.9-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC2T1, clean
2. Update all packages
3. run gok
    

Actual Results:  gok segfaults during starup.

Expected Results:  gok should run.

Additional info:

(as above)

gok's output:
3 event types available
login mode = false
Word prediction dictionary contains a total of 3000 words
Segmentation fault

Comment 1 David Bolter 2004-03-29 17:05:01 UTC
This has been fixed in 0.10.x -- please confirm.

ftp://ftp.gnome.org/pub/GNOME/sources/gok/0.10/

Comment 2 neil v. patel 2004-04-02 03:20:18 UTC
well, the segfault is gone in 0.9.11 -- now it just says it "can't 
read any keyboards". will update to 0.10 (i guess this isn't in 
rawhide yet?).

Comment 3 David Bolter 2004-04-08 14:52:39 UTC
I think this bug can be closed as the remaining bad behaviour is due to:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118504

IMO

Comment 4 neil v. patel 2004-04-08 15:27:18 UTC
agreed.

Comment 5 Nils Philippsen 2004-04-16 14:22:06 UTC
This might just be the case:

nils@gibraltar:~> strace -e open -o /tmp/gok.out gok
nils@gibraltar:~> grep build /tmp/gok.out
open("/usr/src/build/386228-i386/install/usr/share/gok/en_US.UTF-8",
O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOENT (No such file
or directory)
open("/usr/src/build/386228-i386/install/usr/share/gok/en_US",
O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOENT (No such file
or directory)
open("/usr/src/build/386228-i386/install/usr/share/gok/en.UTF-8",
O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOENT (No such file
or directory)
open("/usr/src/build/386228-i386/install/usr/share/gok/en",
O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOENT (No such file
or directory)
open("/usr/src/build/386228-i386/install/usr/share/gok/C",
O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOENT (No such file
or directory)
open("/usr/src/build/386228-i386/install/usr/share/gok",
O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOENT (No such file
or directory)


*** This bug has been marked as a duplicate of 118504 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:01:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.