Bug 117935 - up2date hangs on inter-dependency check
Summary: up2date hangs on inter-dependency check
Status: CLOSED DUPLICATE of bug 117646
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
(Show other bugs)
Version: 1
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-10 08:29 UTC by Mark Baertschy
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Baertschy 2004-03-10 08:29:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
up2date hangs while doing the dependency check if the perl package is
selected. If perl package is not selected, but other packages are,
then up2date completes as normal. This behavior was observed on a new
install of Fedora Core 1 (x86-64 version) on an athlon-64 laptop. The
behavior is very reproducible, but I am can only check it with respect
to the currently available updates. I was able to use up2date to
update every package except for perl.

Version-Release number of selected component (if applicable):
4.1.21-3

How reproducible:
Always

Steps to Reproduce:
1. launch up2date
2. select perl by either choosing it specifically or by choosing
"Select all packages"
3. click "forward" button
    

Actual Results:  progress dialog for testing interdepencies appears
but no progress is every made, window is unresponsive and must be killed.

Expected Results:  interdepency check completes quickly if perl is not
selected, I expect the same when perl is selected.

Additional info:

Comment 1 James Henstridge 2004-03-17 08:13:01 UTC
I observed this as well.  Looking at my web proxy logs, up2date was
trying to download all the .hdr files from download.fedora.redhat.com
(which I haven't seen it do with the i386 architecture).

I eventually decided to try Yum instead, which gave a dependency error
for the xchat package (a dependency on the directory
/usr/lib64/perl5/5.8.1/x86_64-linux-thread-multi which doesn't exist).
 By removing the xchat package, the update finished successfully.  I
expect that it would have using up2date as well.

By the look of it, this is a bug in the perl package, which provides
/usr/lib64/perl5/5.8.1/i386-linux-thread-multi instead.  This problem
has been reported as bug 117646.

Comment 2 Adrian Likins 2004-04-07 20:34:20 UTC

*** This bug has been marked as a duplicate of 117646 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:01:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.