Bug 117646 - missing /usr/lib64/perl5/5.8.1/* for xchat and spamassassin
Summary: missing /usr/lib64/perl5/5.8.1/* for xchat and spamassassin
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl   
(Show other bugs)
Version: 1
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 112600 117935 118253 (view as bug list)
Depends On:
Blocks: 112600
TreeView+ depends on / blocked
 
Reported: 2004-03-06 03:39 UTC by Gene Czarcinski
Modified: 2007-11-30 22:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 22:15:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2004-03-06 03:39:28 UTC
Description of problem:
The i386 package for perl provides a number of /usr/lib/perl5/5.8.n/*
stuff which is NOT provided by the x86_64 package.  This blocks
installing the updated perl package since there are
/usr/lib64/perl5/5.8.1/* required by xchat and spamassassin

Comment 1 Gene Czarcinski 2004-03-08 23:20:43 UTC
OK, this is a bit more complicated than I thought.

xchat requires /usr/lib64/perl5/5.8.1/x86_64-linux-thread-multi

but perl defines a directory as
/usr/lib64/perl5/5.8.1/i386-linux-thread-multi

When this is fixed, be sure to fix the symlink too since it also uses
"i386-linux-thread-multi"

The spamassassin is a separate problem ... I will create a new
bugzilla report.

Comment 2 Miloslav Trmac 2004-03-15 08:48:36 UTC
*** Bug 118253 has been marked as a duplicate of this bug. ***

Comment 3 Gene Czarcinski 2004-03-24 11:36:31 UTC
OK, latest from Warren seems to fix things on the x86_64

http://people.redhat.com/wtogami/temp/perl-5.8.3-16.i386.rpm
http://people.redhat.com/wtogami/temp/perl-5.8.3-16.x86_64.rpm

I can now install


Comment 4 Warren Togami 2004-03-24 11:39:52 UTC
Excellent.  <evil grin>
(Although Chip did all the work.  I just screamed loudly and waved my
arms.)

Expect to see this as an official FC1 update real soon.

Comment 5 Chip Turner 2004-03-29 15:47:43 UTC
this should now be an official update

Comment 6 Adrian Likins 2004-04-07 20:34:22 UTC
*** Bug 117935 has been marked as a duplicate of this bug. ***

Comment 7 Warren Togami 2004-04-22 02:18:56 UTC
*** Bug 112600 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.