This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 118002 - memcpy_fromio, memcpy_toio missing from kernel
memcpy_fromio, memcpy_toio missing from kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 118128 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-10 17:39 EST by Timo Kujala
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 13:58:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Timo Kujala 2004-03-10 17:39:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
memcpy_fromio and memcpy_toio are missing from kernel. Many modules,
including sound drivers refuse to load because of that. Seems that
nobody in the vmlinux uses them so linker leaves them out.

Current kernel: 2.6.3-2.1.253. Happened with .246 kernel too. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile kernel with stock x86_64 options
2.
3.
    

Actual Results:  memcpy_fromio and memcpy_toio are not in vmlinux


Expected Results:  Well, they should be in vmlinux as drivers need it.

Additional info:

The precompiled kernel rpm suffers from this same problem.
Comment 1 Arjan van de Ven 2004-03-12 06:12:11 EST
Andi Kleen just sent a fix to this to Linus; we'll pick that up in a
day or two.
Comment 2 Bill Nottingham 2004-03-12 17:18:07 EST
*** Bug 118128 has been marked as a duplicate of this bug. ***
Comment 3 Timo Kujala 2004-03-17 13:46:54 EST
Fixed in kernel-2.6.4-2.275.

Note You need to log in before you can comment on or make changes to this bug.