Bug 1180303 - can't connect to local desktop since the version released on Dec 25,2014
Summary: can't connect to local desktop since the version released on Dec 25,2014
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: x2goserver
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL: http://bugs.x2go.org/cgi-bin/bugrepor...
Whiteboard:
: 1181628 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-08 19:39 UTC by grizbox
Modified: 2016-09-21 21:00 UTC (History)
3 users (show)

Fixed In Version: x2goserver-4.0.1.18-5.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-17 05:47:15 UTC


Attachments (Terms of Use)

Description grizbox 2015-01-08 19:39:31 UTC
Description of problem: Since the update of x2goserver on Dec 25 (x2goserver.x86_64.4.0.1.18-4.fc20) I can no longer connect to my server with the 
"connect to local desktop" option.  New sessions work fine.

I back leveled my x2goserver to the base version (4.0.1.6-5.fc20) and it works fine.

Version-Release number of selected component (if applicable):
x2goserver.x86_64.4.0.1.18-4.fc20

How reproducible:
always

Steps to Reproduce:
1. Try to connect to local desktop with x2goserver.x86_64.4.0.1.18-4.fc20 installed on server
2.
3.

Actual results:
pop-up dialog states "no accessible desktop found"

Expected results:
my local session to be displayed

Additional info:

Comment 1 Orion Poplawski 2015-01-08 21:31:40 UTC
Think I've found the problem.

Comment 2 Fedora Update System 2015-01-08 21:43:06 UTC
x2goserver-4.0.1.18-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/x2goserver-4.0.1.18-5.fc20

Comment 3 Fedora Update System 2015-01-09 11:55:15 UTC
Package x2goserver-4.0.1.18-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing x2goserver-4.0.1.18-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0473/x2goserver-4.0.1.18-5.fc20
then log in and leave karma (feedback).

Comment 4 grizbox 2015-01-12 13:12:21 UTC
Sorry, can't go to https://admin.fedoraproject.org/updates/FEDORA-2015-0473/x2goserver-4.0.1.18-5.fc20 and login and leave karma as the site won't allow me to create a user account.  I left feedback as an anonymous user.

It now works with the x2goserver-4.0.1.18-5.fc20 package from testing.  Thanks.

Comment 5 Orion Poplawski 2015-01-13 20:22:52 UTC
*** Bug 1181628 has been marked as a duplicate of this bug. ***

Comment 6 Samo Dadela 2015-01-15 08:29:53 UTC
Is there a date when this will be available in FC21?
Thanks.

Comment 7 Orion Poplawski 2015-01-15 15:07:18 UTC
It's already in updates-testing for F21: https://admin.fedoraproject.org/updates/FEDORA-2015-0457/x2goserver-4.0.1.18-5.fc21

Should get push to stable in a couple of days.  Faster if it gets enough positive feedback.

Comment 8 Fedora Update System 2015-01-17 05:47:15 UTC
x2goserver-4.0.1.18-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Samo Dadela 2015-01-26 09:46:32 UTC
Works, now. Thanks.

Comment 10 bryanhoop@gmail.com 2016-09-21 21:00:43 UTC
I'm running into this issue on CentOS 7 w/ EPEL.

https://bugzilla.redhat.com/show_bug.cgi?id=1371690


Note You need to log in before you can comment on or make changes to this bug.