Bug 118101 - rpm missing-files-terminate-build bug
Summary: rpm missing-files-terminate-build bug
Status: CLOSED DUPLICATE of bug 108778
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-11 22:22 UTC by Mike A. Harris
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2004-03-11 22:22:01 UTC
If the file present in the RPM_BUILD_ROOT is a symbolic link, and
it is not listed in one of the %files lists, it will not get
included in the rpm, and rpm will not complain.  It does this in
dist-fc2 for me.

I discovered this after adding the new lib*.so.* files to the
spec file, but forgetting to add the lib*.so symlinks to the file
lists, and later noticing by luck that they were not present in
the generated -devel package.  Since the code I have in the spec
file to generate the .so symlinks works on all .so.* libraries:

    pushd $RPM_BUILD_ROOT%{_x11libdir}
    for lib in *.so.*; do ln -sf $lib ${lib%.so*}.so ; done
    popd

... I was surprised to not get an rpm failure error, since I know
rpm is checking because it complained about other missing files.

Let me know if I should bugzilla this, or if it is a quickie fix
not needing that.

...

Date: Thu, 11 Mar 2004 10:27:00 -0500 (EST)
From: Elliot Lee <sopwith@redhat.com>
To: Mike A. Harris <mharris@redhat.com>
Content-Type: TEXT/PLAIN; charset=US-ASCII
Subject: Re: rpm missing-files-terminate-build bug

> Let me know if I should bugzilla this, or if it is a quickie fix
> not needing that.

So it doesn't get lost, bugzilla please!

-- Elliot

Comment 1 Jeff Johnson 2004-03-11 22:39:43 UTC

*** This bug has been marked as a duplicate of 108778 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.