Bug 108778 - RFE: check-files doesn't catch unpackaged symlinks
RFE: check-files doesn't catch unpackaged symlinks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul Nasrat
: FutureFeature, Patch
: 118101 146329 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2003-11-01 16:46 EST by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 13:49:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Mdk patch for this issue (1.23 KB, patch)
2004-01-04 08:33 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2003-11-01 16:46:30 EST
As discussed in
https://www.redhat.com/mailman/private/rpm-list/2003-October/msg00170.html,
it'd be nice if check-files and friends would catch unpackaged
symlinks too.

Modifying check-files to use

   find $RPM_BUILD_ROOT ! -type d | LC_ALL=C sort > $FILES_DISK

...doesn't quite do what I expected, it makes rpmbuild whine about
dangling symlinks even if they're listed in %files.
Comment 1 Ville Skyttä 2004-01-04 08:33:26 EST
Created attachment 96758 [details]
Mdk patch for this issue

Here's a patch from Mandrake's rpm-4.2-25mdk which seems to apply to this
issue.
Comment 2 Jeff Johnson 2004-03-11 17:39:46 EST
*** Bug 118101 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Johnson 2005-03-25 12:32:52 EST
Checked in on HEAD and rpm-4_4.
Comment 4 Mark Hatle 2005-04-02 10:08:57 EST
*** Bug 146329 has been marked as a duplicate of this bug. ***
Comment 5 Warren Togami 2005-04-02 18:03:47 EST
Paul can we have this fixed in FC4?
Comment 6 Paul Nasrat 2005-05-17 13:49:38 EDT
Will be in rpm 4.4.1-19

Note You need to log in before you can comment on or make changes to this bug.