Bug 118133 - Still seeing segfault from bug #112718 on MSI K7T, even with kudzu-1.1.36.1-1
Summary: Still seeing segfault from bug #112718 on MSI K7T, even with kudzu-1.1.36.1-1
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-12 11:21 UTC by Rudy Eschauzier
Modified: 2014-03-17 02:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 18:28:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb trace of kudzu segfault (1.14 KB, text/plain)
2004-03-16 20:09 UTC, Rudy Eschauzier
no flags Details
Output of kudzu -p (3.45 KB, text/plain)
2004-03-17 07:25 UTC, Rudy Eschauzier
no flags Details

Description Rudy Eschauzier 2004-03-12 11:21:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I have been seeing bug #112718 on my MSI K7T. After updating to kudzu-
1.1.36.1-1 the segmentation fault is still there.

Version-Release number of selected component (if applicable):
kudzu-1.1.36.1-1

How reproducible:
Always

Steps to Reproduce:
1. boot Fedora Core 1 on MSI K7T
2.
3.
    

Actual Results:  The graphical boot gets interrupted and reports 
segmentation fault in Kudzu

Expected Results:  The graphical boot to continue without segfault

Additional info:

Comment 1 Bill Nottingham 2004-03-12 19:10:54 UTC
Can you get a backtrace?


Comment 2 Rudy Eschauzier 2004-03-13 10:33:22 UTC
Yes, but I will need some instructions on how to run the backtrace.

Comment 3 Bill Nottingham 2004-03-15 16:35:09 UTC
Install the kudzu debuginfo file from the debug directory of the updates.

Then, run:

gdb /usr/sbin/kudzu

Enter 'r' to run the program

And, when it segfaults, enter 'bt' for a backtrace.

Comment 4 Rudy Eschauzier 2004-03-16 20:09:20 UTC
Created attachment 98580 [details]
gdb trace of kudzu segfault

Comment 5 Rudy Eschauzier 2004-03-16 20:11:47 UTC
See attached trace. Had to run from console, KDE went haywire when
running Kudzu from there

Comment 6 Bill Nottingham 2004-03-16 20:32:25 UTC
rpm -V kudzu shows no changes, correct?

Can you attach the output of kudzu -p?

Comment 7 Rudy Eschauzier 2004-03-17 07:25:22 UTC
Created attachment 98601 [details]
Output of kudzu -p

Comment 8 Rudy Eschauzier 2004-03-17 07:26:23 UTC
rpm -V shows up empty. See attached file for output of kudzu -p.

Comment 9 Bill Nottingham 2004-03-17 07:57:39 UTC
hwconf.c:696 says:

 if (dev->device && isAliased(cf,dev->device,dev->driver)!=-1

So, it shouldn't get there with dev->device == NULL. Hm, will have to
test some more.

Comment 10 Rudy Eschauzier 2004-03-31 07:11:22 UTC
Any progress? Anything I can do to help?

Comment 11 Bill Nottingham 2004-04-01 04:30:36 UTC
Nope, no progress... it really looks like a 'that can't happen'
things. Unless the backtrace is screwed up. :/

Comment 12 Rudy Eschauzier 2004-04-01 08:22:51 UTC
Any way I can check if the backtrace is screwed up? Anything else I 
can do?

Comment 13 Bill Nottingham 2005-04-28 18:28:00 UTC
Closing bugs on older, no longer supported releases. Apologies for any lack of
response. Please open a new bug if this persists on a current release, such as
Fedora Core 3.


Note You need to log in before you can comment on or make changes to this bug.