Bug 118182 - /etc/fonts/fonts.conf multi-arch install conflict
/etc/fonts/fonts.conf multi-arch install conflict
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Owen Taylor
:
: 121230 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-12 16:31 EST by Jeremy Katz
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.2.1-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 15:03:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2004-03-12 16:31:48 EST
/etc/fonts/fonts.conf contains a timestamp in a comment which leads to
a file conflict when attempting to install both the i386 and x86_64
versions of fontconfig on an x86_64 box.  

(Note: needed for x86 OOo which is shipped on x86_64)
Comment 1 Warren Togami 2004-04-10 22:18:24 EDT
Justin this is fairly serious, you probably want to make sure it gets
fixed.

Jeff, more of a general RPM question:
Even if this bug were fixed by making the file exactly the same
between the two archs, would it fail and conflict in the event of the
file being modified by something else before installing the other arch?
Comment 2 Warren Togami 2004-04-17 23:52:01 EDT
http://togami.com/~warren/archive/2004/fontconfig-2.2.1-multiarch_date_conflict.patch
At first I made this patch, but then I realized there is the remote
possibility of builds succeeding and the files will still conflict if
the two build servers are only a second apart when the date rolls
over.  I do not want to take that risk so instead used this to remove
the timestamp entirely.

diff -u -r1.36 -r1.37
--- fontconfig.spec	10 Mar 2004 17:21:56 -0000	1.36
+++ fontconfig.spec	18 Apr 2004 03:53:29 -0000	1.37
@@ -12,7 +12,7 @@
 Summary: Font configuration and customization library
 Name: fontconfig
 Version: 2.2.1
-Release: 8.1
+Release: 9
 License: MIT
 Group: System Environment/Libraries
 Source: http://fontconfig.org/release/fontconfig-%{version}.tar.gz
@@ -34,6 +34,7 @@
 
 BuildRequires: freetype-devel >= %{freetype_version}
 BuildRequires: expat-devel
+BuildRequires: zlib-devel
 BuildRequires: perl
 # For nodocs patch
 BuildRequires: /usr/bin/automake-1.4
@@ -113,6 +114,9 @@
 # Remove unpackaged files
 rm $RPM_BUILD_ROOT%{_libdir}/*.la
 
+# Fix multiarch timestamp conflict
+sed -i 's/^<\!-- Font directory list configured on.*//'
$RPM_BUILD_ROOT%{_sysconfdir}/fonts/fonts.conf 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -158,6 +162,10 @@
 %endif
 
 %changelog
+* Sat Apr 17 2004 Warren Togami <wtogami@redhat.com> 2.2.1-9
+- #118182 Fix multiarch timestamp conflict
+- BR zlib-devel
+
 * Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
 - Rebuild
 
hopefully can hit rawhide soon
Comment 3 Owen Taylor 2004-04-19 11:13:10 EDT
*** Bug 121230 has been marked as a duplicate of this bug. ***
Comment 4 Justin M. Forbes 2004-05-06 15:03:05 EDT
This is fixed in the currently shipping fontconfig-2.2.1-10. Closing
as rawhide
Comment 5 John Flanagan 2004-09-02 01:42:02 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-410.html

Note You need to log in before you can comment on or make changes to this bug.