Bug 118193 - rhythmbox crashes as soon as any file is played
rhythmbox crashes as soon as any file is played
Status: CLOSED DUPLICATE of bug 116086
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-12 20:11 EST by Michael Wiktowy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full bug-buddy crash report output saved as a file (19.32 KB, text/plain)
2004-03-12 20:15 EST, Michael Wiktowy
no flags Details

  None (edit)
Description Michael Wiktowy 2004-03-12 20:11:15 EST
Description of problem:

rhythmbox crashes with the following on the console:

** (rhythmbox:3845): CRITICAL **: file dparammanager.c: line 319
(gst_dpman_attach_dparam): assertion `G_PARAM_SPEC_VALUE_TYPE
(dpwrap->param_spec) == GST_DPARAM_TYPE(dparam)' failed
rhythmbox: pcm_plug.c:882: snd_pcm_plug_hw_params: Assertion `err >= 0'
failed.
                                                                        
       
(gnome_segv:3852): Gtk-WARNING **: Ignoring the separator setting

after a audio file is chosen and the play button is clicked.

Steps to reproduce the crash:
1.  open rhythmbox
2.  import directory of audio files
3.  select any file and click play button

Expected Results:
I would expect the song to play.

How often does this happen?
Every time.

Additional Information:
XMMS plays the same audio files in the same location perfectly if the
ALSA output is selected.
Playing audio files within nautilus does not work either.
Sound for quake3 does not work (as reported in bug 117744 at
bugzilla.redhat.com ... see that bug for full lspci and lsmod of my
system)

The shortened verion of my lspci and lsmod are:

00:05.0 Multimedia audio controller: nVidia Corporation nForce
MultiMedia audio [Via VT82C686B] (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97
Audio Controler (MCP) (rev a1)

snd_pcm_oss            42532  0
snd_mixer_oss          13952  2 snd_pcm_oss
snd_intel8x0           29736  1
snd_ac97_codec         53384  1 snd_intel8x0
snd_pcm                84232  2 snd_pcm_oss,snd_intel8x0
snd_timer              25220  1 snd_pcm
gameport                3968  1 snd_intel8x0
snd_page_alloc          8580  2 snd_intel8x0,snd_pcm
snd_mpu401_uart         7296  1 snd_intel8x0
snd_rawmidi            21408  1 snd_mpu401_uart
snd_seq_device          6280  1 snd_rawmidi
snd                    43748  9
snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7520  2 snd
Comment 1 Michael Wiktowy 2004-03-12 20:15:02 EST
Created attachment 98507 [details]
full bug-buddy crash report output saved as a file

Couldn't send it directly via bug-buddy since my sendmail is not set up for my
SMTP server.
Comment 2 Nils Philippsen 2004-03-22 06:40:36 EST

*** This bug has been marked as a duplicate of 116086 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.