This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 116086 - Rhythmbox crashes with Alsa GStreamer Sink
Rhythmbox crashes with Alsa GStreamer Sink
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Colin Walters
:
: 118193 120540 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-17 22:30 EST by Jerry O. Dueitt, Jr.
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 11:13:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry O. Dueitt, Jr. 2004-02-17 22:30:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Rhythmbox will crash when playing if the GStreamer properties have 
ALSA set as the default sink. If the default sink is changed back to 
OSS playback will occur and Rhythmbox will not crash. 

Version-Release number of selected component (if applicable):
rhythmbox-0.6.5-1

How reproducible:
Always

Steps to Reproduce:
1. Set the default sink for GStreamer to be ALSA
2. Attempt to play something in Rhythmbox
    

Actual Results:  Rhythmbox will crash

Expected Results:  Rhythmbox will play and not crash

Additional info:

The error that is output on the console is:
rhythmbox: pcm_plug.c:882: snd_pcm_plug_hw_params: Assertion 'err>= 
0' failed.
Comment 1 sangu 2004-02-18 00:51:46 EST
Please see : http://bugzilla.gnome.org/show_bug.cgi?id=129299

------- Additional Comments From Ronald Bultje 2004-01-02 18:46 -------

We won't fix this. It's fixed properly in HEAD CVS (which will become
0.8.0) and all 0.7.x releases.

My reason to not close it is simply so others will not open similar
bugs. ;). I'll close this when we've released 0.8.0.
Comment 2 Alexander Larsson 2004-03-03 10:57:36 EST
We have gstreamer 0.7.5 now, which is supposed to have the fix
according to the above. Does this still happen?
Comment 3 sangu 2004-03-03 12:23:26 EST
No, this problem doesn't happen.

gnome-media 2.5.4-2, gstreamer/gsteamer-plugins 0.7.5-1 and rythmbox
0.7 cvs (109 patch). And no wonder, they are unstable.
Comment 4 Warren Togami 2004-03-19 02:33:08 EST
Please clarify, is this problem solved and can we close this report?
Comment 5 Nils Philippsen 2004-03-22 06:32:07 EST
This still happens here (attempt to play an ogg file from rhythmbox):

nils@gibraltar:~> rhythmbox
 
** (rhythmbox:14390): CRITICAL **: file dparammanager.c: line 337
(gst_dpman_attach_dparam): assertion `G_PARAM_SPEC_VALUE_TYPE
(dpwrap->param_spec) == GST_DPARAM_TYPE (dparam)' failed
 
(rhythmbox:14390): GStreamer-CRITICAL **: file gstcaps.c: line 1178
(gst_caps_structure_fixate_field_nearest_int): assertion
`gst_structure_has_field (structure, field_name)' failed
 
(rhythmbox:14390): GStreamer-CRITICAL **: file gstcaps.c: line 1178
(gst_caps_structure_fixate_field_nearest_int): assertion
`gst_structure_has_field (structure, field_name)' failed
rhythmbox: pcm_plug.c:882: snd_pcm_plug_hw_params: Assertion `err >=
0' failed.
 
(gnome_segv:14398): Gtk-WARNING **: Ignoring the separator setting
nils@gibraltar:~> rpm -q gnome-media gstreamer rhythmbox
gnome-media-2.5.5-2
gstreamer-0.8.0-1
rhythmbox-0.6.8-2
nils@gibraltar:~>
Comment 6 Nils Philippsen 2004-03-22 06:40:37 EST
*** Bug 118193 has been marked as a duplicate of this bug. ***
Comment 7 Colin Walters 2004-04-02 10:13:12 EST
This is an alsa bug.  There's nothing I can do about it.  See:
http://bugzilla.gnome.org/show_bug.cgi?id=134007
Comment 8 Colin Walters 2004-04-14 22:08:01 EDT
*** Bug 120540 has been marked as a duplicate of this bug. ***
Comment 9 Nils Philippsen 2004-04-15 02:59:54 EDT
Just wanted to note that Rhythmbox plays Ogg files correctly now for
me (with Rawhide of yesterday). Haven't checked yet whether it uses
the ALSA gstreamer sink or not though.
Comment 10 Colin Walters 2004-04-15 11:13:47 EDT
Thanks for following up. 

Rhythmbox never changes your gstreamer sink itself - it just uses
whatever you have configured in GConf.
Comment 11 Sitsofe Wheeler 2004-05-27 10:15:14 EDT
This looks like a dup of bug 119958. Perhaps 119958 should be left
open as an obvious dup target so it shows up in people's queries?

Note You need to log in before you can comment on or make changes to this bug.