Bug 118207 - Trying to add an ISDN connection, get exception when saving
Trying to add an ISDN connection, get exception when saving
Status: CLOSED DUPLICATE of bug 116024
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-13 10:15 EST by Alf Hogemark
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alf Hogemark 2004-03-13 10:15:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
I try to use the Internet Connection Wizard to add an ISDN connection.
The wizard asks me for all the info, and then I'm back in the "main"
network gui.
As soon as I try to save the configuration, I get an exception in a
dialog.


Component: system-config-network
Version: 1.3.15
Summary: TB5afc6cd6 NCDevice.py:291:save:KeyError: 'IPv6Init'
Traceback (most recent call last):
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 744, in on_activateButton_clicked
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 942, in on_deviceActivateButton_clicked
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 361, in save
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 381, in saveDevices
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/NCDeviceList.py",
line 246, in save
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/NCDevice.py",
line 291, in save
KeyError: 'IPv6Init'

Local variables in innermost frame:
confkey: IPV6INIT
self: Device.AutoDNS=true
Device.Dialup.HangupTimeout=600
Device.Dialup.ProviderName=FriSurf
Device.Dialup.DefRoute=true
Device.Dialup.Authentication=+pap -chap
Device.Dialup.Password=ipto482
Device.Dialup.PhoneNumber=81545000
Device.Dialup.Login=alfhoge
Device.Dialup.EncapMode=syncppp
Device.Dialup.DialMode=manual
Device.Dialup.Areacode=
Device.Dialup.Prefix=1533
Device.Hostname=
Device.Type=ISDN
Device.Netmask=
Device.BootProto=dialup
Device.Device=ippp0
Device.OnBoot=false
Device.IP=
Device.DeviceId=FriSurf
Device.AllowUser=true
Device.Gateway=

selfkey: IPv6Init
conf: <netconfpkg.NCDevice.ConfDevice instance at 0xf692e3ec>


Version-Release number of selected component (if applicable):
system-config-network-1.3.15-1.1

How reproducible:
Always

Steps to Reproduce:
1. Start "Internet Connection Wizard"
2. Add ISDN connection
3. When I try to save the configuration, get an exception
    

Additional info:

Component: system-config-network
Version: 1.3.15
Summary: TB5afc6cd6 NCDevice.py:291:save:KeyError: 'IPv6Init'
Traceback (most recent call last):
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 744, in on_activateButton_clicked
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 942, in on_deviceActivateButton_clicked
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 361, in save
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 381, in saveDevices
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/NCDeviceList.py",
line 246, in save
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/NCDevice.py",
line 291, in save
KeyError: 'IPv6Init'

Local variables in innermost frame:
confkey: IPV6INIT
self: Device.AutoDNS=true
Device.Dialup.HangupTimeout=600
Device.Dialup.ProviderName=FriSurf
Device.Dialup.DefRoute=true
Device.Dialup.Authentication=+pap -chap
Device.Dialup.Password=ipto482
Device.Dialup.PhoneNumber=81545000
Device.Dialup.Login=alfhoge
Device.Dialup.EncapMode=syncppp
Device.Dialup.DialMode=manual
Device.Dialup.Areacode=
Device.Dialup.Prefix=1533
Device.Hostname=
Device.Type=ISDN
Device.Netmask=
Device.BootProto=dialup
Device.Device=ippp0
Device.OnBoot=false
Device.IP=
Device.DeviceId=FriSurf
Device.AllowUser=true
Device.Gateway=

selfkey: IPv6Init
conf: <netconfpkg.NCDevice.ConfDevice instance at 0xf692e3ec>
Comment 1 Harald Hoyer 2004-03-15 04:36:37 EST

*** This bug has been marked as a duplicate of 116024 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.