Bug 1182145 - mount.glusterfs doesn't support mount --verbose
Summary: mount.glusterfs doesn't support mount --verbose
Keywords:
Status: CLOSED DUPLICATE of bug 1564890
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
: 1289787 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-14 14:10 UTC by Sandro Bonazzola
Modified: 2018-10-08 10:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-08 10:13:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sandro Bonazzola 2015-01-14 14:10:08 UTC
using
 glusterfs-fuse-3.6.2beta1-0.55.git443cda3.el7.centos.x86_64
 util-linux-2.23.2-20.el7.x86_64

# mount --help|grep verbose
 -v, --verbose           say what is being done

# mount --verbose -t glusterfs 192.168.1.108:/he /tmp/test
/sbin/mount.glusterfs: illegal option -- v
Usage: /sbin/mount.glusterfs <volumeserver>:<volumeid/volumeport> -o<options> <mountpoint>
Options:
man 8 /sbin/mount.glusterfs
To display the version number of the mount helper: /sbin/mount.glusterfs -V

Comment 1 Niels de Vos 2015-01-14 16:21:28 UTC
The xlators/mount/fuse/utils/mount.glusterfs.in script would need to accept the -v option. Possibly it should add the --log-file=/dev/stderr to the parameters passed to the glusterfs binary.

Comment 2 Anand Avati 2015-06-30 14:10:54 UTC
REVIEW: http://review.gluster.org/11469 (scripts: add mount --verbose option) posted (#1) for review on master by Prasanna Kumar Kalever

Comment 3 Anand Avati 2015-07-08 12:54:09 UTC
REVIEW: http://review.gluster.org/11469 (scripts: add mount --verbose option) posted (#2) for review on master by Prasanna Kumar Kalever

Comment 4 JS 2015-12-09 00:26:11 UTC
*** Bug 1289787 has been marked as a duplicate of this bug. ***

Comment 5 Vijay Bellur 2016-04-28 06:55:04 UTC
REVIEW: http://review.gluster.org/11469 (scripts: add mount --verbose option) posted (#3) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 6 Vijay Bellur 2016-04-29 16:58:47 UTC
REVIEW: http://review.gluster.org/11469 (scripts: add mount --verbose option) posted (#4) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 7 Vijay Bellur 2016-04-29 18:20:05 UTC
REVIEW: http://review.gluster.org/11469 (scripts: add mount --verbose option) posted (#5) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 8 Amar Tumballi 2018-10-08 10:13:06 UTC
This is now fixed in master by https://review.gluster.org/21295

*** This bug has been marked as a duplicate of bug 1564890 ***


Note You need to log in before you can comment on or make changes to this bug.