Bug 1564890 - mount.glusterfs: can't shift that many
Summary: mount.glusterfs: can't shift that many
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: mainline
Hardware: Unspecified
OS: Linux
high
urgent
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
: 1182145 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 16:31 UTC by Alex
Modified: 2019-03-25 16:30 UTC (History)
7 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:30:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github gluster gluster-kubernetes issues 458 0 None None None 2018-09-18 15:00:13 UTC

Description Alex 2018-04-08 16:31:51 UTC
Description of problem:
The command "mount.glusterfs" always says "can't shift that many". This just happens on Ubuntu 16.04 on all versions i've tried (4.0, 3.12, 3.7)

Version-Release number of selected component (if applicable):
glusterfs 3.7, 3.12 and 4.0

How reproducible:
Checked it on fresh ubuntu nodes (scaleway.com and digital-ocean). It happens on every fresh Ubuntu 16.04 node.


Steps to Reproduce:
1. Log In on an Ubuntu Node 
2. Install the PPA or use the default Ubuntu version
3. Try to call mount.glusterfs


More information here:
https://github.com/gluster/gluster-kubernetes/issues/458

Comment 1 Amar Tumballi 2018-09-18 13:41:33 UTC
Alex, I see that actually, changing the shell type worked for you.

Niels, should we change it in codebase itself?

Comment 2 Niels de Vos 2018-09-18 15:00:13 UTC
Changing #!/bin/sh to #!/bin/bash is not recommended as it pulls in more dependencies (bash is considered large for container/cloud images).

It would be better to fix the problem in the script, and do the correct shifting of arguments (maybe call 'shift' 2x instead of 'shift 2'?).

Comment 3 Worker Ant 2018-09-28 08:59:51 UTC
REVIEW: https://review.gluster.org/21295 (fuse: prevent error message \"can't shift that many\") posted (#1) for review on master by Niels de Vos

Comment 4 Worker Ant 2018-10-01 04:27:15 UTC
COMMIT: https://review.gluster.org/21295 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- fuse: prevent error message "can't shift that many"

On systems where /bin/sh is not Bash, running plain mount.glusterfs
gives the unhelpful error "can't shift that many".

The argument parsing can be a little improved. Adding a check for the
number of arguments, minimal two (Gluster ip:/volume, and mountpoint),
but possibly more (-o, -v etc.).

With the additional check, running 'mount.glusterfs -h' now shows the
following messags:

    Usage: /sbin/mount.glusterfs <server>:<volume/subdir> <mountpoint> -o<options>
    Options:
    man 8 mount.glusterfs
    To display the version number of the mount helper: /sbin/mount.glusterfs -V

Change-Id: I50e3ade0c6217fab4155f35ad8cb35d99d52e133
Fixes: bz#1564890
Reported-by: Alexander Zimmermann <alexander.zimmermann96@gmail.com>
Signed-off-by: Niels de Vos <ndevos@redhat.com>

Comment 5 Amar Tumballi 2018-10-08 10:13:06 UTC
*** Bug 1182145 has been marked as a duplicate of this bug. ***

Comment 6 Shyamsundar 2018-10-23 14:48:30 UTC
Fix is present only against mainline, moving the bug to mainline, for required tracking.

Comment 7 Shyamsundar 2019-03-25 16:30:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.