Bug 1182481 - Possible to delete ContentViewVersion used by Composite Content View Components
Summary: Possible to delete ContentViewVersion used by Composite Content View Components
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.6
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Tazim Kolhar
David O'Brien
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1122832 sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-01-15 09:03 UTC by Peter Vreman
Modified: 2019-08-15 04:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-15 07:21:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1786 normal SHIPPED_LIVE Satellite 6.1.2 bug fix update 2015-09-15 11:20:04 UTC

Description Peter Vreman 2015-01-15 09:03:51 UTC
Description of problem:
The relation between a Composite Content View and the used ContentViewVersion is not strict. After re-publishing a ContentView and you delete the old ContentViewVersion then the list of Composite Content View components is empty.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create ContentView A
2. Publish ContentView A
3. Create CompositeContentView B
4. Add ContentView A (version 1) to CompositeContentView B
5. Publish CompositeContentView B
6. Publish ContentView A (version 2)
7. Delete ContentView A version 1
8. List Components of CompositeContentView B

Actual results:
List is empty

Expected results:
Delete of ContentView A version 1 is not allowed, not breaking the list of Components of CompositeContentView B

Additional info:

Comment 1 RHEL Product and Program Management 2015-01-15 09:13:42 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Justin Sherrill 2015-07-23 14:01:21 UTC
This is likely a higher priority as it leaves the system in an inconsistent state. 

The delete goes all the way through to the finalize phase (deleting everything in pulp and candlepin in the process), and then errors out.

Comment 4 David O'Brien 2015-08-06 09:09:09 UTC
Is there any workaround or other advice I can put in a rel note?

thanks

Comment 7 Mike McCune 2015-08-21 03:07:13 UTC
ACK to the rel-note draft. Looks good

Comment 8 Brad Buckingham 2015-08-24 19:14:54 UTC
Created redmine issue http://projects.theforeman.org/issues/11472 from this bug

Comment 9 Brad Buckingham 2015-08-24 19:20:56 UTC
Katello PR: 
   https://github.com/Katello/katello/pull/5439

Comment 12 Tazim Kolhar 2015-08-27 10:23:13 UTC
VERIFIED:
# rpm -qa | grep foreman
foreman-vmware-1.7.2.35-1.el6_6sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.3-1.el6_6sat.noarch
foreman-1.7.2.35-1.el6_6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el6_6sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el6_6sat.noarch
tyan-gt24-03.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
tyan-gt24-03.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-libvirt-1.7.2.35-1.el6_6sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.19-1.el6_6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.5-1.el6_6sat.noarch
foreman-postgresql-1.7.2.35-1.el6_6sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el6_6sat.noarch
tyan-gt24-03.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-selinux-1.7.2.13-1.el6_6sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.20-1.el6_6sat.noarch
foreman-ovirt-1.7.2.35-1.el6_6sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el6_6sat.noarch
foreman-compute-1.7.2.35-1.el6_6sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el6_6sat.noarch
foreman-gce-1.7.2.35-1.el6_6sat.noarch
foreman-proxy-1.7.2.5-1.el6_6sat.noarch
foreman-debug-1.7.2.35-1.el6_6sat.noarch

steps:
1. Create ContentView A
2. Publish ContentView A
3. Create CompositeContentView B
4. Add ContentView A (version 1) to CompositeContentView B
5. Publish CompositeContentView B
6. Publish ContentView A (version 2)
7. Delete ContentView A version 1
8. List Components of CompositeContentView B

Delete of ContentView A version 1 is not allowed, not breaking the list of Components of CompositeContentView B

Comment 14 errata-xmlrpc 2015-09-15 07:21:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1786


Note You need to log in before you can comment on or make changes to this bug.