Bug 1182796 - [RFE][HC] - volume creation for hyperconverged use case should only allow replica 3 volumes
Summary: [RFE][HC] - volume creation for hyperconverged use case should only allow rep...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: ovirt-4.0.0-beta
: 4.0.0
Assignee: Sahina Bose
QA Contact: RamaKasturi
URL:
Whiteboard:
: 1183308 (view as bug list)
Depends On:
Blocks: HC_Host_4.0 Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2015-01-15 22:48 UTC by Paul Cuzner
Modified: 2016-08-12 14:05 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
When a cluster is set to hyper-converged mode (with both Virt and Gluster services enabled), for Gluster storage, only replica 3 volumes are supported.
Clone Of:
: 1183308 (view as bug list)
Environment:
Last Closed: 2016-08-12 14:05:25 UTC
oVirt Team: Gluster
ylavi: ovirt-4.0.0?
bmcclain: planning_ack+
sabose: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
Replica 3 (152.75 KB, image/png)
2016-08-11 08:40 UTC, RamaKasturi
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 57136 master NEW webadmin: gluster vol defaults in case of HC cluster 2016-05-06 13:11:00 UTC

Description Paul Cuzner 2015-01-15 22:48:14 UTC
Description of problem:
for a hyperconverged use case, the glusterfs volume layout MUST be replica 3 - rhevm 3.5 currently exposes all volume types to the user which could lead to invalid configurations and data loss.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
This RFE requests that when a volume is created in a cluster that has both virt and glusterd enabled, the volume type pull down box should be restricted to show just replicated with the replica count automatically set to 3.

Additional info:

Comment 1 Yaniv Kaul 2015-11-26 16:25:28 UTC
Paul - I'm quite sure we have such an enforcement in 3.6 - can you check?

Comment 2 Yaniv Lavi 2015-11-27 00:01:12 UTC
(In reply to Yaniv Kaul from comment #1)
> Paul - I'm quite sure we have such an enforcement in 3.6 - can you check?

We added this to storage domain logic. But this rfe is not showing that option in the gluster management ui.

Comment 3 Red Hat Bugzilla Rules Engine 2015-12-01 15:35:55 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Sahina Bose 2016-03-08 09:38:24 UTC
*** Bug 1183308 has been marked as a duplicate of this bug. ***

Comment 5 Sandro Bonazzola 2016-05-02 10:08:11 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 8 RamaKasturi 2016-08-11 08:39:38 UTC
Verified and works fine with ovirt-engine-4.0.2.2-0.1.el7ev.noarch.

When cluster is in hyperconverged mode, i.e with virt and gluster service enabled, click on create new volume shows replicate and as of now it does not show replicate count till volume types are refreshed. Raised a bug for this https://bugzilla.redhat.com/show_bug.cgi?id=1366167.

Once volume Types are refreshed, New volume dialog displays Type as Replicate and Replica count as "3". Attached a screenshot for the same.

Comment 9 RamaKasturi 2016-08-11 08:40:15 UTC
Created attachment 1189958 [details]
Replica 3


Note You need to log in before you can comment on or make changes to this bug.