Bug 1183308 - [RFE][HC] - volume creation for hyperconverged use case should only allow replica 3 volumes
Summary: [RFE][HC] - volume creation for hyperconverged use case should only allow rep...
Keywords:
Status: CLOSED DUPLICATE of bug 1182796
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: anmol babu
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks: HC_Host_4.0
TreeView+ depends on / blocked
 
Reported: 2015-01-18 13:01 UTC by Yaniv Lavi
Modified: 2016-03-08 09:39 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1182796
Environment:
Last Closed: 2016-03-08 09:38:24 UTC
oVirt Team: Gluster
ylavi: ovirt-4.0.0?
ylavi: planning_ack?
sabose: devel_ack+
ylavi: testing_ack?


Attachments (Terms of Use)

Description Yaniv Lavi 2015-01-18 13:01:45 UTC
+++ This bug was initially created as a clone of Bug #1182796 +++

Description of problem:
for a hyperconverged use case, the glusterfs volume layout MUST be replica 3 - oVirt 3.5 currently exposes all volume types to the user which could lead to invalid configurations and data loss.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
This RFE requests that when a volume is created in a cluster that has both virt and glusterd enabled, the volume type pull down box should be restricted to show just replicated with the replica count automatically set to 3.

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 11:00:03 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Sahina Bose 2016-03-08 09:38:24 UTC

*** This bug has been marked as a duplicate of bug 1182796 ***


Note You need to log in before you can comment on or make changes to this bug.